Ultrawide resolution + Intel Xe Graphics

Hello. I have Zorin 16 installed on my desktop pc with intel 6500 with intel HD Graphics 530 connected to my ultrawide monitor with resolution of 2560 x 1080 and it works just fine.

I just got a notebook Dell Vostro 3500 with the i7-1165G7 (intel Xe Graphics (TGL GT2) and installed Zorin 16, but it doesn't recognize the 2560x1080 resolution when I connect it through hdmi on my monitor. Only up to 1920x1080 60hz

I tried everything, and already installed this diver but didn't work: GPGPU: Ubuntu 20.04 (focal)

I also tried to manually add the resolution using:
xrandr --newmode but when I select the newly added resolution, nothing happens and it goes back to the original one: 1920x1080

It only works on 2560x1080 if I add it with 40hz, which is terrible haha
Captura de tela de 2021-08-30 22-20-55

Captura de tela de 2021-08-30 22-28-43

I'm not very used to linux, so I don't know what else I can do. I don't know if intel graphics are being used or what.. Does anyone have a clue?

What effect does 33hz have?

Also, what is the output of uname -a on both machines; the working and the non-working?

Hello! :wink: thanks for the reply
the output of uname -a for both machines are 5.11.0-27-generic #29~20.04.1-Ubuntu SMP x86_64 x86_64 x86_64 GNU/Linux

I also tried with 33hz and it works just as with 40hz, but it's not as fluid as 60hz.
Do you know if there's a way to check if intel graphics are being used? :pray:

You can run in terminal:

sudo lshw -c video

If you have inxi installed, you can also use inxi -G.

Is Secure boot enabled in your EFI settings?
You may need the Ubuntu OEM kernel:

sudo apt install linux-oem-20.04 && sudo reboot

Thank you, @Aravisian. Unfortunately installing ubuntu oem kernel didn't solve the issue. I have security boot enabled.

I still can manually add the 2560x1080 60hz to the resolution setting, but still can't select it. I goes back to 1920x1080

inxi -G

  Device-1: Intel driver: i915 v: kernel 
  Display: x11 server: X.Org 1.20.11 driver: i915 resolution: 1920x1080~60Hz 
  OpenGL: renderer: Mesa Intel Xe Graphics (TGL GT2) v: 4.6 Mesa 21.0.3 


 sudo lshw -c video
       descrição: VGA compatible controller
       produto: Intel Corporation
       fabricante: Intel Corporation
       ID físico: 2
       informações do barramento: pci@0000:00:02.0
       nome lógico: /dev/fb0
       versão: 01
       largura: 64 bits
       clock: 33MHz
       capacidades: pciexpress msi pm vga_controller bus_master cap_list rom fb
       configuração: depth=32 driver=i915 latency=0 mode=1366x768 visual=truecolor xres=1366 yres=768
       recursos: memória de E/S:600-5ff memória de E/S:400-3ff irq:129 memória:6000000000-6000ffffff memória:4000000000-400fffffff porta de E/S:4000(tamanho=64) memória:c0000-dffff memória:4010000000-4016ffffff memória:4020000000-

I think all distros would have the same problem. I also tried with the main Ubuntu that already came installed on the notebook, but still got the same issue. I think it's a driver issue.

I'll install windows later today to test it out. It will probably work.

Can you please revert to the previous kernel and remove the OEM kernel?
Your Mesa is good...

You are not alone in this:


Reading around and around and around...
One possibility is that the HDMI cable cannot handle the clock rate. Or the chip can't. If you test this in Windows, and it works, they may not be your issue.
But if you have a rugged HDMI cable layinabout unused, it may be worth trying that out...

Thank you very much :pray:

I have found the solution. There's none :clown_face:

After I installed windows, it didn't work either so I look up on dell's site and have found a bunch of users very angry because dell just decided to limit the resolution output to 1920x1080 in a lot of their notebooks. So no matter if the gpu supports it, they block it :angry:

Resolution on external monitor limited to 1920 x 1080 using HDMI | Dell US

Thank you anyways :wink: You're awesome.

Also, if you don't mind, can you tell me how to revert to the previous kernel and remove OEM kernel? :eyes:


If you tap the left shift key - or hold it down, during Boot Up, it should bring up the Recovery Grub menu - You will see Advanced Options for Zorin OS. Select that option and arrow key down to the 5.11.0-27 kernel listed. Enter in and boot normally.
Once logged in, open terminal and run:

sudo apt remove --purge linux-oem-20.04 && sudo apt autoremove

1 Like

Accurate as always. Thank you @Aravisian :pray:

1 Like

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.