Unable to boot into fresh Zorin install - "No Bootable Device"

I am trying to install Zorin 16 Core on an Acer Inspire E E5-571-598P laptop that I have laying around to revamp it.

So, I just bought a new SSD, and then had Windows 11 installed on it, it worked completely fine, I used it for a bit (remembered why I hate Windows) and then decided to install Zorin OS on it instead (bc it is clearly the superior OS). Installation completed without any issues. Except that now the laptop doen't boot. It just shows the message "No Bootable Device" when I turn it on. If I press F12 to get the boot menu, it shows no HD/SSD option to boot. SSD does show up on BIOS properly though.

I performed the installation in UEFI mode with secure boot disabled. I am unsure what could be causing the issue. If I boot on a live environment I can verify that the OS is indeed written on the SSD, it is just not detected at boot up.

How can I fix this?

This is the error message when UEFI is enabled:

This is the error message when Legacy mode is enabled:

Can u boot the pendrive again and run repair zorin os app

I can do that. Is that the actual name of the application?

You could try running Boot Repair, which I believe should be an option there on your ZorinOS installation pendrive.

Question: Have you disabled Secure Boot etc before trying to install ZorinOS. See this advice: Before you install

Installed on a nvme disk and have raid mode enabled ?

Secure boot disabled ?

I will try Boot Repair in a bit, thanks.

I have first installed it with secure boot enabled. Then I reinstalled it with secure boot disabled.

Regarding the link, Win is not installed anymore so I can't disable Fast Startup or Bitlocker encryption (if they were ever on).

It is an SSD, and I don't think raid is enabled. Would I check that in the bios?

This is what is generated by the summary option of Boot-Repair:

Perhaps this is the problem?

============================== Boot Info Summary ===============================
 => No boot loader is installed in the MBR of /dev/sda.

When you ran boot repair, did you run it from a LiveUSB?
Boot repair was unable to continue as the drive was mounted.

This is normal as you are using EFI boot instead of MBR boot.

Boot Repair suggestion was to reinstall grub-efi-amd64-signed

sudo apt install --reinstall grub-efi-amd64-signed

Yes, I am on a live environment.

I ran the command you posted in the live and then ran the recommended repair option of Boot-Repair (I am assuming this is what I was supposed to do). It said an error occurred during the repair.

This is the file boot repair generated:

Other than a file descriptor error (that can be ignored for now as it is unrelated), I am not seeing a specific error. If you have, please let me know.

I am seeing any unknown device listed.

This points to a likely need for Updating the BIOS prior to installing an Operating System.

One thing you might try just to see if it can work - Use rEFInd to install:

I was able to install it on the live via the ppa, but I am unsure how to install in on the SSD. I ran sudo refind-install but that didn't do it. What command should I run?

Also, I noticed that when the boot menu comes up, it doesn't say UEFI "USB name" (like it does on my main machine), it says instead USB HDD "USB name". Could that be a symptom of the issue? That perhaps it is loading the UEFI "version" of the USB?

Is the USB Drive in question the sdb listed?

Yes it is

Ok, I think I've fixed it!!

For some reason I needed to configure the option "Select an UEFI file as trusted for executing" in the Security tab in BIOS, as shown in the first part of this video: How to Fix Ubuntu Doesn't Boot After Installing in UEFI, No Bootable Device Ubuntu (Easy Tutorial) - YouTube

Unsure why it is so, seems to be an Acer thing, as the laptop shown in the video is also an Acer. Thanks for the help everyone!

P.S. In the video the guy says you can keep Security Boot on if you like, but I had to turn it off for the fix to apply.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.