Unable to boot Zorin os pro


I installed Zorin os successfully but I get this when I try to boot up. I don't think the kernel is version 6+ which reading through the forum seems to be a potential fix but I have no idea how to do that since I cannot even get to the system to use apt to update anything. Or in recovery mode, there is no network connection so the apt commands fail.

Thank U!

I'm on Asus Zephyrus g 16 (13900h and 4070 NVIDIA mobile GPU)

At the initramfs prompt you see - type


and hit the enter key.
Please relay what you see on the screen after doing so.

So I rebooted my device. That initramfs no longer appears. Just the invalid log size error above and the ones before it

I got this after waiting a while

The AE errors can be ignored as not relevant.

Tainted kernel, though...

Please go back into recovery, arrow key down to Enable Networking and hit enter.

Once enabled, back up to the Recovery menu and arrow key down to Root - Drop to Prompt.
In the prompt, run sudo apt update just to ensure that Net is working. If so, and if your idea that the 6+ kernel is needed, run:

sudo add-apt-repository ppa:tuxinvader/lts-mainline

sudo apt update && sudo apt install linux-generic-6.02

Once that completes (Watch the prompt for failures or errors) back out of the recovery menu and proceed to try to boot.

It says cannot resolve the domains which makes sense cz even if I enable networking I still didn't connect to a wifi. How can I connect to a wifi from recovery?

Edit: I tried searching how to connect to wifi but none of the guides worked. I only have "lo" as the device showing and it doesn't find any devices when I use sudo iw lo scan

If Wifi also needs a driver, what about connecting via Ethernet?

Unfortunately I dont have an ethernet cable :confused: this is frustrating. I'm not sure what the original error is. Thank U for Ur help btw! Does the list of errors I got when booting indicate anything at all?

Is there any iso with the updated kernels?

The AE Not Found can be ignored. That is a warning, not an error. It only means that the ACPI table had to fallback to default due to the Manufacturer not including the data in the tables.

That Plymouth or kernel is tainted is an issue. And an older kernel should not show as tainted.

How fresh is this install? I would just re-do the install if it is fresh. A corrupted file during the installation process is a likely culprit.

I have never used Zorin before so this is the first time installing it. I reinstalled 3 times and all 3 times I get the exact same list of "errors" or warnings

Edit: it's also worth mentioning that all 3 times it installed successfully and I rebooted and this happens on the first boot all 3 times. So I have never actually reached the desktop

The 4070 may also be a cause of Tainted kernel due to the proprietary drivers.

There is not, but it also should not be needed. An older kernel may not support all the newest hardware, but should not create such a no-boot issue.

At any point, did you ever select with Safe Graphics?

Have you ensured that Secure Boot is disabled in the BIOS EFI settings?

Yep I tried installing the first time with NVIDIA then I tried safe graphics then I tried the default first option that just said install Zorin OS

Fast boot is disabled
Secure boot is disabled
Vmd controller is disabled

Oh and if I try to re-enable vmd controller is when I reach that initramfs state

Whack in exit at that prompt- then relay what it says.

Ah I did! Check the log haha, there's an exit and there is some stuff right after it

1 Like

I missed seeing that...

Did you use Full DIsk Encryption?

Have no idea how to check. Is that a bios option or the windows's drive encryption?

The only other thing worth noting is that error (which could be nthg) after the installation finishes. And that last command takes forever, on all 3 occasions I hit enter after waiting for it to do anything and it just reboots. That screenshot is after every installation

It is an option offered during the Zorin OS installation. It is a checkbox that you can select by clicking the box.
It asks if you want to install with full disk encryption.