Unable to boot Zorin os pro

Where can I find wifi drivers? Maybe if I get those I can jst run apt with internet

Another installation attempt.. I get this error after installation finishes

Please ensure that you read and pay attention to all the words being presented.

Instead, you used sudo apt install and it noted in the terminal that it was "selecting the apt linux package instead of acting on the .deb package you downloaded and moved over. This resulted in it trying to access the web.

Note the locations on that repository for additional packages:



Ah my bad, I double clicked to run but it ended up "Pending installation" for more than 20mins and nothing happened, so I googled and found this comment on reddit:
Reddit comment

Is there a way run the apt command forcing it to use .deb file rather than connecting to the internet? I will attempt to download/ install the provided headers/image/modules now.

Again thanks for your patience! Still new to all this.

Yes, sudo dpkg -i named-deb-file.deb from a terminal opened within the directory that the deb package is in. If you do not want to cd to that directory or right click within that folder in file manager selecting "Open in terminal", then you can use the Path to the package. For example, if it is in your home downloads folder:

For example from within the directory

sudo dpkg -i linux-generic-6.02_6.2.16-0_amd64.deb

From outside of the directory:

sudo dpkg -i ~/Downloads/linux-generic-6.02_6.2.16-0_amd64.deb

I've had zero luck trying to boot even the lite version.. I've tried the standard, the lite again and both pro versions and none boot. My email to zorin group no response yet.. Tbh I wanted a user friendly linux distro that I even paid 60~ AUD for it and so far it has not worked.. Really bad experience.

Are you using Spinning HDD or SSD?
If SSD, is it eMMC or nVME?
In your BIOS / EFI settings, are you set to AHCI or to RAID?

1TB M.2 PCIe 4.0 NVMe SSD

As for AHCI or raid, on Asus motherboard I found online that is controlled by "VMD controller" which if disabled is set to AHCI. Mine is set to disabled. If I enable it and try to go through installation, I can't even find my hard drive and can't install.

Oh yes... You have said this twice, now. After so many threads and posts, I can sometimes repeat a question. Sorry about that.

I have the same and have had no troubles with it. So I think we can discount the drive as being the issue.

In this post, we see "beyond end of device"

Can we have a look at your partitions using a screenshot of Gparted?

That's alright! Here's a photo of the partitions from the installer.

Which of these partitions is Zorin OS?
I only see Windows... OR I see the cause of the problem....
Can you clarify if nvme01np3 is the Zorin Partition?

Well in that screenshot there is no Zorin OS ahhaha. I deleted the partitions because the previous installations did not boot and was trying to re-install again the lite pro cz that's the only one that worked before

Ah, ok. I was starting to think you had formatted the Zorin Partition to NTFS, which is Windows only format. I'm bummed now - it seemed the thread was on the verge of a solution.

So far, Pro Lite 16.3 Works? But 16.1 and 16.2 of either Lite or Core (Pro) does not work?

Update! Reinstalling the pro lite and using the kernel image U sent I was able to boot using 6.2 and wifi works!!! I ran Sudo apt upgrade and everything is upgraded. How can I upgrade from Pro lite to Pro?!

Thank you so much, btw.. I'm glad I am getting somewhere now

Moving from Lite to Core (Or Pro Lite to Pro) is not an Upgrade. It is an equivalent sidways motion...:stuck_out_tongue:

From the app menu, launch Zorin Upgrader and follow the Prompts.

Also I'm trying scaling but instead of zooming in.. it zooms out? X2 scaling makes everything X2 smaller rather than bigger..

That is odd. I just tested this on my copy of Zorin OS Lite from Settings > Appearance > Settings > Window scaling.
1x is normal and 2x was... huge... In fact it trimmed the windows so much I could not use the GUI to reset it to 1x. I had to open a terminal and run

xfconf-query -c xsettings -p /Gdk/WindowScalingFactor -s 1

to get my windows back to normal size.

For the Zorin upgrade. It says no upgrades available. Is it the menu item "upgrade Zorin os"? I don't see a "Zorin upgrader"


I just launched that app and took a look... it offers to move to Pro Lite or Education Lite. No offer for Pro. Hmmm...

You can still install the Pro Desktop directly from the terminal. I am not sure the exact command for that - may need to get back to you on that...

Side question (sorry trying to get this into working state). NVIDIA drivers from yh additional divers don't work