Unable to install any linux os on my system

For the past two days, I have been trying to install a Linux OS. I tried Ubuntu, but it didn't install. I also tried Pop!_OS and Zorin OS, but none of them worked. I spent the whole day trying to install, but no Linux OS is getting installed. Now, as a last attempt, I am trying Zorin Lite, but it's not getting installed either. It took around 2 hours for copying files, but the installation didn't happen. I don't know why.

I have 8GB of RAM, and my processor is Intel(R) Pentium(R) CPU G620 @ 2.60GHz.

Are you getting an error message?

If so, can you please describe it here.

1 Like

32bit or 64bit?

In your BIOS / EFI settings, are you set to AHCI or to RAID?

This is what I'm getting after restart .
And I'm sure that it didn't installed perfectly.
Tell me what is this and how can I run my os perfectly...I'm new to linux.

Those errors mean that there is something likely wrong with your Disk Connection. There may be corrosion on the contact points of the cable or the cable itself may have failed.
It is possible that it is a disk error, but a cable connection error is more likely.

Just looked on ark.intel.com and it says it's 64 bit.

1 Like

So what should I do now? What is the solution for this? Do I need to change the cable or the hard disk? Or is there any other solution from your side?

Over the internet... I cannot offer a command or anything that can repair hardware.
The first step is to check the integrity of the connection to the disk. Oftentimes, it really is the simplest thing.
I cannot count on both hands and feet how many times a cable came loose or even unplugged inside of an electronic device, a car, a computer...


For me if sector error then hard disk is not big.
I often have error that when hard disk is full and installation cannot be reading because is full that why sector error cannot write and read.

Thank you for your help. The problem you have mentioned turned out to be accurate, and your solution worked. However, after the installation, my system has become slow. Opening any application takes a lot of time and it's quite slow overall...i thought linux will make my system fast.. i installed zorin lite because i want todo coding on vscode, and I'm not able todo it...
help me

As strange as it may sound, I would retrace your steps with the sata cable. While you may have improved the connection; it may still need further improving. If the connection is good enough to transfer data, but still a poor connection, it can really slow down communication speeds with the disk.

I would not expect quickness with this CPU. It is not a bad clock rate (2.6GHz), but not a blazing fast one.

Check your Hardware Temps. You can use Psensor app to monitor in real time and see if anything is getting too hot. You can use Dust-Off compressed air to try clearing out vents, fans, ports and the like.

You can check your startup software list and see if anything is set to autostart that does not need to be or that can be delayed slightly (Often, a 20 second offset) so that you do not have too much trying to initialize all at once.

If the issue with this thread is resolved and the cause of the trouble in this thread is not the cause of current processing speeds, I think the additional questions will be moved to a new topic.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.