Unable to install Zorin 16 Pro - Can't install GRUB Fatal error

First of all, I am new to Linux, and I am a user, not a computerexpert.

I have been trying to install zorin (and tried Mint as well to see if that works) but I keep getting the message Cannot install GRUB, this is a fatal error.
I have tried all kind of things, try first and istall from there, install directly, let the installationsoftware do everything, set my own partitions. But I keep getting this message, and there it stops. No bootable operating system found when I restart the computer.
It is a microsoft Surface book 3, with a 1 TB SSD, no windows next to Zorin, it's gone anyway ;-).

Maybe the part of a syslog may be helpfull? I have a 175 page syslog, but don't know how to upload it or attach it. For as far as I understand it, there is a problem with the disk, no boot partition or someting like that, but I am not sure about that, because the installation should create partitions itself?
Thanks for any help, I do not know what to do to solve this.


Hi and welcome to the forum.
First off I would point you to this pre-installation advice and checklist. Before you install

Once you can confirm you have turned off Secure Boot, Fast Startup etc and still no grub then please report back.

Mint have to download the Grub, so you need to be online. I do not know about Zorin as I do not needed to be online to install. Use Rufus for Mint and Zorin. In Rufus make sure that partition is set to GPT.Make sure that the BIOS set for uefi ( probably is already since they come with win10). What I would recommend is from live distro(usb) go to gparted and see what is on your hdd. Since you wipe the windows, while in gparted click on device and partition as GPT. That will wipe the hdd clean so you can install Zorin or MInt

I am here as a last resort, not a first. But as said have tried a lot of things already. Secure boot on and off, downloaded Zorin several times, burn on USB with several programs including Rufus.
I do not need an internet connection for installation, but also tried with connection and without. Installation starts normally, everything looks fine, until it crashes on grub installation. It somehow does not recognize the right partition. At least that is what I think.
Windows is gone, the SDD is empty at the moment, so adjusting things via Windows is not possible.
Is there a clear tutorial for which partitions to create manually, I tried that as well, but am uncertain if I did that right?

For now, have a nice Christmas!

1 Like

The Grub is looking for sda and can not find it. Use gparted to clean the hdd and see (while in gparted) to see if your hdd is reported as sda. You may have some win10 partition left

1 Like

I tried gparted. It's a bit annoying because the writing is very small.

There is no SDA hard disk, it is nvme0n1.
The disc has four partitions I created (no windows partitions left):
...p1 fat32 partition is empty 487 MB flagged bios_grub
...p2 ext4 installed Zorin OS16Pro 46.57GB
...p3 linux-swap flagged swap
...p4 ext4 partition is empty
That's all. If I startup the computer says there is no bootable operating system.

I tried boot-repair from the test environment from USB, no succes.
I somehow have to install a bootloader that starts the computer and Zorin

If you do an install using the "Something Else" option. There is a point where you choose where you bootloader goes. I for one overlooked this on one occassion, so can get missed.

The picture below is from an old tutorial, but should indicate that important step.

1 Like

Another suggestion: Partitioning during installation

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.