Unable to mount HDDs

I have just installed Zorin OS yesterday after a few months of cursing at Ubuntu. I am transitioning from windows 7. Everything works so far, but I am unable to mount 2 of my HDDs. They did work in Ubuntu, so I am not sure what the issue is.
I see them in the disks app, but the edit mount options are greyed out.

when you click on the partition, does the Mount Disk button appear on the toolbar just beneath the partition window?

No, nothing else appears from what you see in the screenshot. It does say under Contents: Unknown (promose_fasttrack_raid_member). Not sure what that means, but the disk is not in any RAID array.

Well, it may not be in a RAID array right now, but this hard drive was probably setup in RAID previously. Usually when you don't see a play button for mounting, thats an indicator that the drive is not formatted and partitioned for use.

You can format and partition the drive from the 3-dots upper right hand side of APP.

But I don't want to format them. They have all my stuff in it... Is there any way to get them working without formatting? Like I mentioned, they did work without issue on Ubuntu and they work on Windows as well.

Looks like the drive has lost its partition.

I'll have a look if I can still access it from windows.

If the drive still works under Windows, here are the steps I want you to follow...

(1) Backup everything that is on the drive, onto another hard drive.

(2) Once backed up, Switch back to Zorin OS

(3) Load the DISKS utility, select your drive, click on the 3 dots, and choose format disk.

(4) Format the disk GPT. Once formatted...

(5) Create a new partition, make the partition EXT4

The drive will no longer be usable on the Windows filing system, but it will work on Linux now. But I want you to do more still. Once the drive has been partitioned...

(6) Click the gear icon and go to EDIT MOUNT PARTITIONS.

Put checkmarks in Mount At System Startup, and Show In User Interface

Now, as long as the drive is connected to the computer, it will be auto mounted, and ready for use when the system starts up. And it should show up in your Nautilus file manager window too. Hope this helps.

Can I make it NTFS? not sure if my NAS and media center can read EXT4. Also I still need windows for some programs, that are made explicitly hard to run on linux....

This was a very important piece of information that we didn't have before. Is this a NAS drive, meaning, did you pull it out of your NAS server?

NTFS is a Windows based file system, that no doubt your NAS server can utilize as well. However, getting the NTFS file system to work under Linux is not easy, and I don't know the procedure to make that work.

It is not a nas drive. I just had a directory mounted, its just a separate 1TB hdd that was NTFS. I don't really understand how can it not work since it worked on ubuntu just 3 days ago :slight_smile:
Edit: the drives work fine on windows.

Did you try pop os as well ? 21.04 ?

Yes, a while back. I didn't like the interface. xubuntu was okish, but the apps are a mess, and what ticks me off most about linux is the complicated file sharing. I couldn't get some of my folder shares working on my network.... Zorin seems to be most "windowsy", but my 1st days using, and already problems out of nothing...
Funnily enough, it does mount the NTFS disk where windows are :smiley:

Well in zorin i did not have any issues with ntfs drives (2 internal, 4 external), however sometimes 1 game refused to boot from a ntfs drive. Moved it to a ext4 partition and the issue was gone.

Well in this case it seems partitions are messed up someway that linux cares, but windows doesn't. I can only see the device, but not partition. Maybe some outside tool might help solve this issue. Don't really have the space to back up 2 TB at the moment...

I'm most likely wrong... Believe I had a similar issue back when I installed Zorin 12.4. Or maybe Mint. What fixed it for me was taking the cover off my pc, disconnecting the hard drive, re-booted with it not connected. Powered down again, re-connected, then powered back on. It was something very, very similar. Because now whenever I install a new OS, I disconnect the HD's as to ensure I don't lose anything..

1 Like

Worth a try. I'll report back when I have the chance to test.

1 Like

So disconnecting and reconnecting them didn't work. Any more ideas? :slight_smile:

Have you installed ntfs-3g since these drives are formatted for Windows?

sudo apt install ntfs-3g exfat-fuse

I also threw in exfat-fuse, just in case.

tired. no luck. also tried gparted. doesn't work. I guess the only way to fix this is to format it...