Unintended single-click on input fields

Installed Zorin OS Lite 16.3. on an old Medion Notebook (Intel i3) and using a Logitech 310 mouse (USB-type). When hovering over an input field, even the password field, when the mouse pointer is within the range of the input field, after 1-2 seconds an unintended single click appears, making it hard to enter a password or an url (tested on both browsers Google Chrome and Firefox). The touchpad is not as aggressive but still an unwanted single-click happens there as well.
Have added an output of lspci here.

00:00.0 Host bridge: Intel Corporation 3rd Gen Core processor DRAM Controller (rev 09)
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200 v2/3rd Gen Core processor PCI Express Root Port (rev 09)
00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
00:14.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB xHCI Host Controller (rev 04)
00:16.0 Communication controller: Intel Corporation 7 Series/C216 Chipset Family MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation 7 Series/C216 Chipset Family USB Enhanced Host Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation 7 Series/C216 Chipset Family High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 7 Series/C216 Chipset Family PCI Express Root Port 1 (rev c4)
00:1c.1 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 2 (rev c4)
00:1c.3 PCI bridge: Intel Corporation 7 Series/C216 Chipset Family PCI Express Root Port 4 (rev c4)
00:1d.0 USB controller: Intel Corporation 7 Series/C216 Chipset Family USB Enhanced Host Controller #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation HM76 Express Chipset LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 7 Series Chipset Family 6-port SATA Controller [AHCI mode] (rev 04)
00:1f.3 SMBus: Intel Corporation 7 Series/C216 Chipset Family SMBus Controller (rev 04)
01:00.0 3D controller: NVIDIA Corporation GK208M [GeForce GT 740M] (rev a1)
03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 07)
04:00.0 Network controller: Intel Corporation Centrino Wireless-N 2230 (rev c4)

Thanks for any idea to stop that behavior.

I wonder if this is some sort of setting that can be tweaked as I remember similar behavior with MXLinux. Try to run mousetweaks -s to kill the daemon* and see if this makes a difference.

*I'll admit it, I wrote it this way because it sounds kinda cool.

1 Like

Hello thanks for help. Unfortunately mouse tweaks does not run on the machine. I tried to look for different drivers or a driver update, but was not successful so far. Problem unfortunately still persists.

This sounds like "Dwell Click."

Can you launch Settings and navigate to Accessibility. Move to the Mouse tab.
Ensure that both checkboxes listed are Unchecked.
Unless you are aware of a need for any other assistive technologies, I would actually ensure all boxes in all tabs are unchecked just to save yourself from other annoyances.

Hi there, thanks for the tip. I checked the setting and both checkboxes are unchecked. Still no change to the weird behavior so far.

Under Settings > Mouse and Touchpad, check if there is an option listed for "hover click" or "Dwell click".

Do you or did you ever have a package named mousetweaks installed?

Finally, you can check ~/.config/xfce4/xfconf/xfce-perchannel-xml for any settings for mouse clicks.
You might just go the easy route and

mv ~/.config/xfce4/xfconf/ ~/.config/xfce4/xfconf-bk/

And restart then test.

I suggested this because it seems to be installed right out of the box on my VM, and had that option that seemed related to this issue. Is it not? The fact that happens with both touchpad and external mouse made me think it's related to a setting.

1 Like

I just checked and it is also already installed on my Zorin OS Lite 16.3


This should have had the same effect as uninstalling it - except it being only temporarily halted and would be restored upon reboot.

1 Like

I tried this method, but it was not successful.

Have you rebooted recently?

I just removed mouse tweaks from the machine and rebooted. Still no change.

Under Settings > Mouse and Touchpad
Move to the Behavior tab
What is Double Click
Time - set to?
Distance - set to?

Under Devices
What is
Sensitivity - set to?

Double click time is set to 400ms
Distance is set to 5px
Sensitivity is set to 4px

These are all normal...

I am stumped. Given all available information, the above suggestions supplied should have worked.
You said that both the touchpad and a plug-in mouse exhibit the same behavior?

Not exactly the same, the touchpad is a little more laggy in single click, the Logitech Mouse is very fast.

What is the output for

ls /usr/share/X11/xorg.conf.d/

insgesamt 36
drwxr-xr-x 2 root root 4096 Jul 26 02:59 .
drwxr-xr-x 5 root root 4096 Okt 22 21:47 ..
-rw-r--r-- 1 root root 92 Aug 24 2022 10-amdgpu.conf
-rw-r--r-- 1 root root 1350 Mär 29 2023 10-quirks.conf
-rw-r--r-- 1 root root 92 Okt 22 2019 10-radeon.conf
-rw-r--r-- 1 root root 1429 Aug 13 2019 40-libinput.conf
-rw-r--r-- 1 root root 590 Apr 6 2020 51-synaptics-quirks.conf
-rw-r--r-- 1 root root 1751 Apr 6 2020 70-synaptics.conf
-rw-r--r-- 1 root root 3458 Mär 11 2020 70-wacom.conf

What should I look at in particular?

Checking if there were any custom configuration files there that may affect cursor behavior (Mouse as well as touchpad). There are not - the files listed are all the ones that come with the system.

I have been searching the web on this and I cannot find any new information that we have not already covered.

Have you tested your hardware? I know this may seem superfluous since your touchpad shows the same behavior... However, the touchpad may respond to the mouse if the mouse is plugged into a USB port during use.

Switching to a different USB port, cleaning the mouse and testing touchpad with no mouse connected after a reboot may help give us a clue...

Perhaps trying a live USB with ZorinOS Core, or some other distribution, may give us a clue. If the behavior is the same then we know it must be something related with the hardware itself... maybe?