UNRESOLVED - Change boot order (dualboot with Windows)

Folks, This may be a software issue but my lack of knowledge thinks that I'm discussing hardware choices (as in which hard drive) so forgive me if this is not the correct area to look for help in.
I have Zorin running on my laptop perfectly but just now have chosen to install Zorin OS 16 on my desktop too but as a dual boot option until all my old Windows stuff can be left behind. It all installed smooth as silk but now when I start the machine, press DEL to open the bios to choose what I want booted, Win or Zorin, no matter what I choose the machine always starts windows. Grrr.
For some back up, I installed Zorin on a separate Hard drive keeping Windows completely separate yet somehow sneaky Windows still has some control at startup.
Let me know where to look or what to try all in an effort to convince the silly computer that when I want it to boot Zorin from its HD (this choice appears as Ubuntu) to please do so! Sadly it always boots into Windows (10)
Thanks in advance. PC

I use dual boot too. Well triple boot that is, but they are all on one SSD.

I know that when you use separate drives in the bios you can use the Function key to show when booting. This will give you the opportunity to boot in one or the other drive.

1 Like

You are continuing instead of saving and executing the new boot order. I would take dasjdoom's advice and use f8 or f12 to choose which device to boot into instead of changing the boot order every time.

1 Like

Edited title for clarification.
If OP think of a better title, please let me know.

Thanks everyone for replying but the issue is that regardless of what I choose when in the BIOS, the system always starts windows. So my question is this: How do I make sure that my computer actually looks to the second hard drive ONLY when booting? I would understand if I got a message "cannot boot from this Hard Drive" or something similar, but I do not. All that happens is that the computer continues to boot into Windows 10. HELP.... :slight_smile: All the best, PC

Since software solution is always tricky for me,
I improvised a physical solution for myself - pluggable.
It works only on desktops though.


French Press, that is a very cool solution. Before I get to that situation, I will continue to ask for help to see if there is a way to stop intrusive Win10 from deciding when and how to boot. Fingers crossed I can make this work but erasing Windows altogether may come sooner than later right? TY, PC

1 Like

With this setup, boot order is not an issue :slight_smile:
Both my desktops (main and sub) got exactly the same pluggable system.

The only true dual-boot I have is 10 years old Acer Aspire on which I dual-boot Zorin16 and Windows 11 (not a typo).

1 Like

Pridanc, it's not the boot order you should change but look for the function key. Similar like this.


It's the function keys, mine is F10, which allows you, while starting up, to choose which OS to boot. It's available in the Bios settings.

1 Like

dasjdoom, thanks for the suggestion. My system opens the BIOS with the DEL key pressed from which I can then select the drive with Zorin on it but I still get Windows. I will try going straight to the boot menu at startup to see if that helps. Meanwhile I'll poke around to see if there are any other things I can do to stop this Windows craziness. Any more ideas and I'm happy to try them! PC

Some people are against using grub-customiser but I used it to change the name of Windows from Windows 10 to 11 without any problem. It can also change the boor order.

(2nd method)


Frenchpress, thanks for the information. I will try Appuals as I am getting nowhere.
For more information, when I select F8 while the computer is coming on, it takes me to this screen. (I have chosen each option one at a time to attempt to open Zorin with no luck.)

PO is my "C" drive where Windows is installed.

P1 is my "G" drive where only Zorin is installed.

When you click on the G drive to look at it, there is only one folder, which is Labeled EFI.

Click on EFI and you can now see 2 more folders.

One is labeled BOOT (with 3 files in it. bootx64.efi, fbx54.efi, and mmx64.efi.

The other file is labeled UBUNTU (with 4 files in it. grub.cfg, grubx64.efi, mmx64.efi, shimx64.efi)

As can be seen the only place there is mention of GRUB is in the Ubuntu file. If Grub should be elsewhere let me know where and what files to move or copy.

I am at a complete loss as computers are not my thing so I could use some thoughts/help. Many thanks, PC

This is normal.
In the EFI installation, the 1sto boot partition is in FAT32.
Windows can only see/access to it, since the other Linux partition is in ext4.

See the partition table of my Zorin installation.

(you can do without swap partition- I need it for virtualization).

Windows is looking at only the first boot/efi partition.

While you can use Windows boot manager such as EasyUEFI (commercial non-free), it would be simpler to use grub as a boot manager since it can see all Windows file system along with Linux file system.

If you are able to boot into Zorin OS at all, once logged in, open a terminal with ctrl+alt+t and use os-prober to identify the recognized OS's:

sudo apt install os-prober

Then run

sudo update-grub

If this does not work, you may boot up from LiveUSB and run Boot repair:


It sounds like grub didn't get installed. If you run the installer, or grub boot repair, it should fix the issue.

In the installer, choose something else, mount the existing zorin partition without format on /, choose the windows boot manager partition for the grub in the drop down button under the partition window. Ensure you have all the partitions mounted that are necessary in the partition window (ext4 without format) and install.

1 Like

Harvey, thanks for your suggestions. I've gone back to basics and have followed your How TO Partition to a T and this is on a 3 Terrabyte HD.
My partitions are
EFI Fat32 500meg unused 499.72meg
Swap Ext4 33meg unused 27.87met
System Ext4 200meg unused 4 meg (??? Odd yes?)
Home Ext4 2.73TB unused 2.73TB
Once I hit INSTALL NOW there were all kinds of "this is too small" and a few other choice words but per your instructions I clicked through them. All seemed to be going well until the entire thing stopped with a "not enough space to complete install". Um...what?
I'm going back to try it all again and this is fun so far but just now edging into that "shucks" phase. Any thoughts? Meanwhile I will take pics and make more notes (to share) as I try again! OK, now it is just crashing so I am going to walk away and try again later by starting all over. MANY THANKS as I really appreciated it. PC

The space required is in gigabytes, you allocate barely a gigabyte per partition. You can either multiply the number of gigs you want to use by 1024 (for the exact number) or you can guesstimate at 1000. So it seems you want:

  • 200gb system partition
  • 32gb swap
  • the rest for home (1.73 TB?)

In the partitions part of the installer, use those numbers multiple by a thousand. So your partitions will be:

  • 200,000mb system
  • 32,000mb swap
  • 1,730,000mb home

I'll have to make sure others don't make this mistake. MB is smaller than GB and this is important.

The system is right, you don't have enough space. Redo your partitions at the above sizes.

1 Like

Doh...miss that completely. Proof positive I'm maybe, at best, good to copy instructions. I will make the changes and let you know. Family in for a visit so may be a few days.
Can't thank you enough for your help. Talk soon, PC


I have many times problem dual boot. sudo update-grub doing nothing. Sometimes just accept how it works and stop dreaming and wondering why something working here or there. Every operating system is diffrent.

Pridanc was not complaining... he had inadvertently used gigabytes instead of megabytes, not noticing that gparted is in megabytes. This is an easy thing to overlook when you are not used to installing OS's.

I know there has been some negativity on the forum, but please don't hold everyone responsible for that when they are clearly clueless and asking for help (no offense meant Pridanc).

1 Like