UNRESOLVED - Fingerprint Sensor not Working - Dell Inspiron 5406


I'm having an issue with my fingerprint sensor, it doesn't show to enable in user settings. I've followed a bunch of guides but none worked. Can someone provide me a guide to install it's driver? Thanks in advance.

Hi and welcome to the forum. Can you please post the output from lspci ? You can use the terminal for that

1 Like

Sure, thanks :slight_smile:

1 Like

lsusb too please

1 Like

1 Like
sudo sh -c 'cat > /etc/apt/sources.list.d/focal-dell.list << EOF
deb http://dell.archive.canonical.com/updates/ focal-dell public
# deb-src http://dell.archive.canonical.com/updates/ focal-dell public

deb http://dell.archive.canonical.com/updates/ focal-oem public
# deb-src http://dell.archive.canonical.com/updates/ focal-oem public

deb http://dell.archive.canonical.com/updates/ focal-somerville public
# deb-src http://dell.archive.canonical.com/updates/ focal-somerville public

deb http://dell.archive.canonical.com/updates/ focal-somerville-melisa public
# deb-src http://dell.archive.canonical.com/updates focal-somerville-melisa public
sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys F9FDA6BED73CDC22
sudo apt update -qq

sudo apt install oem-somerville-melisa-meta libfprint-2-tod1-goodix oem-somerville-meta tlp-config -y

Reboot and run

sudo pam-auth-update
1 Like

Done, but the fingerprint config didn't show in settings yet.

1 Like

Did you mark it with the star and save it ?

Yep, it's saved.

1 Like

Weird because that should fix your issue. You did reboot ?

1 Like

Yep, i rebooted after running the script and then i enabled the fingerprint option in PAM.

1 Like

i rebooted again and the problem persists :frowning: do you know if there is a way to register my fingerprint at the terminal? Maybe your script worked but it didn't update the settings UI

1 Like

@Aravisian @FrenchPress and idea's on this one ?

1 Like

@jpgalvao, what happens if you change your layouts (lets say to the one that looks like windows) ? Can you check if there is a setting available ?

1 Like

The settings menu didn't changed when i changed the layout

1 Like

Can you check if there is a configuration file ?


You might need root for that

sudo -H nautilus

I don't really... Fingerprint readers in Linux are sadly lacking in much support. I have struggled with the Fingerprint issues many times with about a 30% success rate, at best.

1 Like

I'm playing along with this topic since I've never been able to get the fingerprint reader on my Dell Insprion 5570 to work. I just don't think the hardware is supported.

Following the steps above the pam-configs folder was created, but no config file.

sivartk@Inspiron-5570:/usr/share/pam-configs$ ls -al
total 40
drwxr-xr-x   2 root root  4096 Oct  8 15:39 .
drwxr-xr-x 277 root root 12288 Dec  7 08:02 ..
-rw-r--r--   1 root root   124 Feb 17  2020 capability
-rw-r--r--   1 root root   178 Feb 22  2021 fprintd
-rw-r--r--   1 root root   152 Mar 11  2020 gnome-keyring
-rw-r--r--   1 root root   154 Aug 11  2020 mkhomedir
-rw-r--r--   1 root root   182 Sep  5 20:53 systemd
-rw-r--r--   1 root root   668 Sep 17 01:14 unix

My fingerprint device:
Bus 001 Device 005: ID 27c6:5301 Shenzhen Goodix Technology Co.,Ltd. Fingerprint Reader


If i am not wrong that is the fingerprint file. Can you open it ?

Contents of the file

Name: Fingerprint authentication
Default: no
Priority: 260
Conflicts: fprint
Auth-Type: Primary
        [success=end default=ignore]    pam_fprintd.so max_tries=1 timeout=10 # debug
1 Like