UNRESOLVED - Keyboard not working in live session in Lite

I tried to install Zorin OS 15.3 Lite in another PC, but for some reason, when booting through live usb, the keyboard won’t work. How to fix?

I'm so sorry you are having issues again! I really hope we can help you solve them.

Corsair keyboard? If so, I believe it. Or perhaps the driver isn't being loaded. Do you have another keyboard to plug it to test? Have you tried unplugging your keyboard, and plugging it back in after booted into the system?

You may try:

sudo apt install xserver-xorg-input-all

1 Like

The in-built keyboard is the one that doesn’t work, and unfortunately I don’t have any external keyboards.
The PC is HP Stream x360 Convertible (11-ag002ne)

The keyboard doesn’t work at all so there is no way for me to type that command

Does it work at the Grub menu or in tty?

1 Like

Grub menu is the boot menu right? If so then yes

If you enter Recovery Menu, then Drop to prompt, you can enter installation commands.

1 Like

I’m sorry but how do I enter the recovery menu? I’m still pretty new to Linux

Reboot and when you see the Motherboard splash screen, begin tapping the esc key.
On older systems, it is left shift key.
It is something that may take a couple of tries...


Recovery mode wouldn’t boot so I managed to run the command with a virtual keyboard.
Sadly, nothing happened after I executed it.

Umm... I just now realized you are on LiveUSB. Not installed... Sorry for that.

What type of Computer- year, make and model?

1 Like

No wonder, I was trying for two hours to boot it :upside_down_face:

This is the model:

Ahhh... ok...
What is the output of:

cat /sys/class/dmi/id/chassis_type

(Use copy / paste)

1 Like

The result is 31

1 Like

Are you able to pull up Onboard using mouse and app menu?
That is the On Screen Keyboard.

1 Like

Yes, I can

I was thinking that the system thinks your computer is a tablet and so, disabled the connected keyboard.
Now, I am not sure if this is a good lead or not given you two replies above...

1 Like

So is there any way to fix this?

I have been researching and looking into it...

1 Like