Updated NVidia drivers - now it won't boot

Current Zorin Core OS installed, NVidia 750Ti installed and noticed a new game on Steam was laggier than it should be, I decided to try the open source driver vs the installed proprietary one I had working.

Updated to it, rebooted and now it won’t boot past the BIOS screen, I can’t get past it. Tried holding the left shift down when I reboot, it just stays at the BIOS logo.

Any help is appreciated! I don’t want to reinstall, hell I can’t even get it to pick up my usb thumb drive I used to install Zorin on… Argh.

EDIT I mean Boot Splash screen.
I cant get into grub (ESC / C / Shift) and I cant get it to boot into the boot order, BIOS or anything either. Just locks at the splash.

2nd Edit:
When I unplug my USB drive and reboot it will show three options
Advanced Startup

but my keyboard wont let me choose anything and after ten seconds it boots up the splash screen, freezing again.

Which splash screen are you seeing? One showing the manufacturer logo (example, Asus) or one showing Zorin?
If it is former, use the various suggestions here to get into BIOS - https://www.tomshardware.com/reviews/bios-keys-to-access-your-firmware,5732.html - once in BIOS, I strongly recommend disabling Secure Boot under UEFI. There could be other adjustments you can make but UEFI seems to be the typical problem.
If it is latter, either hold Left Shift OR repeatedly tap Esc (try both) - once you get the recovery menu, try this [SOLVED] Black screen after install

Given your “2nd edit” - your keyboard is likely USB. I have had that issue on an Asus mobo. Try plugging in a PS/2 keyboard.

MOBO Manufacturer (Gigabyte)
Can’t get into BIOS I see the option for F12 / DEL / F9 as options for a split second, tried about 20 times to get into the BIOS, no luck.

Second edit, it’s a wireless USB KB yes.
PS2 KB? I’ll check my tickle trunk but I think Ilm SOL

How about getting rid of all other USB devices? Unplug mouse et al and try with only the keyboard connected?

Tried, but my only KB is a usb/wireless… Not sure what options I have now.

Pretty much PS/2.
My desktops - both Asus mobos of different models - have given me enough USB problems from their Windows days that I have PS/2 keyboards on both. This is a BIOS issue that was aggravated on Windows but never completely went away with Linux.

This is scary. But do not lose hope too quickly. It sounds like it may be as easy as an edit to /etc/default.grub or as complex as booting into the recovery mode and enabling networking, then using terminal to reinstall your graphics drivers. Whenever I had this problem before- Keyboard / Mouse not recognized at boot - It was when I installed the Open Source graphics drivers but did into install the “input-all” line at that time. Installing xserver-org-input-all resolved it.
But Getting There is the First- is it possible - hurdle.

And on this one (You may have tried this already) I have found holding the Left Shift key was ineffective.
Stabbing it furiously with my finger over and over because I don’t want to wipe and reload, however, Worked.

This happens when there is a Flicker Of Time when the MB will register the command, between looking at Grub and Attempting to Load Graphics. You have to catch it during that instant and holding the key down does not register. And it often took me three or more reboots of furious stabbing, too.