Upgrade from Zorin 15 to Zorin 16 problem

root@Zorin15:/home/mike# apt upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 libzpool2linux : Depends: libnvpair1linux (>= 2.0.4-0york0~18.04) but 0.8.4-1~18.04.york0 is installed
              Depends: libzfs2linux (>= 2.0.4-0york0~18.04) but 0.8.4-1~18.04.york0 is installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).
root@Zorin15:/home/mike# apt --fix-broken install
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
  efibootmgr libabw-0.1-1 libcdr-0.1-1 libcmis-0.5-5v5 libe-book-0.1-1 libegl1-mesa libeot0 libepubgen-0.1-1
  libfreehand-0.1-1 libfwup1 libheif1 libllvm7 libllvm8 libllvm8:i386 libllvm9 libllvm9:i386 libmspub-0.1-1
  libmwaw-0.3-3 libnvidia-cfg1-418 libnvidia-cfg1-430 libnvidia-cfg1-440 libnvidia-cfg1-450 libnvidia-common-418
  libnvidia-common-430 libnvidia-common-440 libnvidia-common-450 libnvidia-compute-418 libnvidia-compute-430
  libnvidia-compute-430:i386 libnvidia-compute-440 libnvidia-compute-440:i386 libnvidia-compute-450
  libnvidia-compute-450:i386 libnvidia-decode-418 libnvidia-decode-430 libnvidia-decode-430:i386 libnvidia-decode-440
  libnvidia-decode-440:i386 libnvidia-decode-450 libnvidia-decode-450:i386 libnvidia-encode-418 libnvidia-encode-430
  libnvidia-encode-430:i386 libnvidia-encode-440 libnvidia-encode-440:i386 libnvidia-encode-450
  libnvidia-encode-450:i386 libnvidia-extra-440 libnvidia-extra-450 libnvidia-fbc1-418 libnvidia-fbc1-430
  libnvidia-fbc1-430:i386 libnvidia-fbc1-440 libnvidia-fbc1-440:i386 libnvidia-fbc1-450 libnvidia-fbc1-450:i386
  libnvidia-gl-418 libnvidia-gl-430 libnvidia-gl-430:i386 libnvidia-gl-440 libnvidia-gl-440:i386 libnvidia-gl-450
  libnvidia-gl-450:i386 libnvidia-ifr1-418 libnvidia-ifr1-430 libnvidia-ifr1-430:i386 libnvidia-ifr1-440
  libnvidia-ifr1-440:i386 libnvidia-ifr1-450 libnvidia-ifr1-450:i386 libnvpair1linux libodfgen-0.1-1 libpagemaker-0.0-0
  libreoffice-avmedia-backend-gstreamer libreoffice-pdfimport librevenge-0.0-0 libuutil1linux libvisio-0.1-1
  libwpd-0.10-10 libwpg-0.3-3 libwscodecs0 libzfs2linux libzpool2linux linux-headers-5.0.0-25
  linux-headers-5.0.0-25-generic linux-headers-5.0.0-27 linux-headers-5.0.0-27-generic linux-image-5.0.0-25-generic
  linux-image-5.0.0-27-generic linux-modules-5.0.0-25-generic linux-modules-5.0.0-27-generic
  linux-modules-extra-5.0.0-25-generic linux-modules-extra-5.0.0-27-generic nvidia-compute-utils-418
  nvidia-compute-utils-430 nvidia-compute-utils-440 nvidia-compute-utils-450 nvidia-dkms-418 nvidia-dkms-430
  nvidia-dkms-440 nvidia-dkms-450 nvidia-kernel-common-430 nvidia-kernel-common-440 nvidia-kernel-common-450
  nvidia-kernel-source-430 nvidia-kernel-source-440 nvidia-kernel-source-450 nvidia-utils-418 nvidia-utils-430
  nvidia-utils-440 nvidia-utils-450 rsplib-docs uno-libs3 xserver-xorg-video-nvidia-418 xserver-xorg-video-nvidia-430
  xserver-xorg-video-nvidia-440 xserver-xorg-video-nvidia-450
Use 'sudo apt autoremove' to remove them.
The following additional packages will be installed:
  libnvpair1linux libuutil1linux libzfs2linux
The following packages will be upgraded:
  libnvpair1linux libuutil1linux libzfs2linux
3 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
1 not fully installed or removed.
Need to get 0 B/340 kB of archives.
After this operation, 64.5 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
(Reading database ... 381375 files and directories currently installed.)
Preparing to unpack .../libnvpair1linux_2.0.4-0york0~18.04_amd64.deb ...
Unpacking libnvpair1linux (2.0.4-0york0~18.04) over (0.8.4-1~18.04.york0) ...
dpkg: error processing archive /var/cache/apt/archives/libnvpair1linux_2.0.4-0york0~18.04_amd64.deb (--unpack):
 trying to overwrite '/lib/x86_64-linux-gnu/libnvpair.so.3.0.0', which is also in package libnvpair3linux 2.1.0-0york2~18.04
Preparing to unpack .../libuutil1linux_2.0.4-0york0~18.04_amd64.deb ...
Unpacking libuutil1linux (2.0.4-0york0~18.04) over (0.8.4-1~18.04.york0) ...
dpkg: error processing archive /var/cache/apt/archives/libuutil1linux_2.0.4-0york0~18.04_amd64.deb (--unpack):
 trying to overwrite '/lib/x86_64-linux-gnu/libuutil.so.3.0.0', which is also in package libuutil3linux 2.1.0-0york2~18.04
Preparing to unpack .../libzfs2linux_2.0.4-0york0~18.04_amd64.deb ...
Unpacking libzfs2linux (2.0.4-0york0~18.04) over (0.8.4-1~18.04.york0) ...
dpkg: error processing archive /var/cache/apt/archives/libzfs2linux_2.0.4-0york0~18.04_amd64.deb (--unpack):
 trying to overwrite '/lib/x86_64-linux-gnu/libzfs_core.so.3.0.0', which is also in package libzfs4linux 2.1.0-0york2~18.04
dpkg-deb: error: paste subprocess was killed by signal (Broken pipe)
Errors were encountered while processing:
 /var/cache/apt/archives/libnvpair1linux_2.0.4-0york0~18.04_amd64.deb
 /var/cache/apt/archives/libuutil1linux_2.0.4-0york0~18.04_amd64.deb
 /var/cache/apt/archives/libzfs2linux_2.0.4-0york0~18.04_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

root@Zorin15:/var/cache/apt/archives# dpkg -P libnvpair3linux
dpkg: dependency problems prevent removal of libnvpair3linux:
 libzpool5linux depends on libnvpair3linux (>= 0.8.2).
 zfs-zed depends on libnvpair3linux (>= 0.8.2); however:
  Package libnvpair3linux is to be removed.
 zfsutils-linux depends on libnvpair3linux (= 2.1.0-0york2~18.04).
 libzfs4linux depends on libnvpair3linux (>= 0.8.2).

dpkg: error processing package libnvpair3linux (--purge):
 dependency problems - not removing
Errors were encountered while processing:
 libnvpair3linux

Currently, there is no Upgrade Path from Zorin OS 15 to Zorin OS 16.

Can you please detail what steps you tried so far?

Also, please see here:

1 Like

All I did was

apt update

then
apt upgrade

I was hoping this would upgrade me to Zorin 16.

apt upgrade brings current software and os up to whatever fixes, security updates are available in the current version. It will not take you to the next version of os. Currently, as aravisian has posted, there is no direct upgrade path to 16. You will have to download 16 core and do a fresh install. Because the kernel is 5.11 in 16 and 15.3 has the 5.8 kernel, all apps have to be fresh installed, just like the os, to ensure compatibility.

Check the tutorials and guides section of this forum for a way to backup your installed apps in a list to make it easier to install the software you use regularly.

2 Likes

.... How long had it been since you last did an apt update and upgrade? :expressionless: