!urgent ZorinOS not connecting to ssh

In windows I was using ssh user@ip but in zorin os i see timed out and all the stuff and I can confirm you 10000000% that it is not issue with my server I am still able to connect with windows. Can anyone please help me.


Until you are provided a better answer, you can go to Youtube and search for, how to share files between Linux and Windows, there are awesome video guides, generally better then anything we can write here, that can help you.


Your Tech Support Guru

I am talking about ssh client I have to connect to a server please help me it's too important the only headache I am having is ssh issues in my windows while connecting to my server it give warning like the bla bla fingerprint not bla bla type and I have to type y or n to continue but in linux it directly says time out or hanshake failed.

@Aravisian Got any ideas, your the one with Windows10 experience. @337harvey You got any ideas too, you've used Windows10 haven't you?

I got the same topic here Ubuntu SSH client not connecting to VPS, however putty is? - Ask Ubuntu but literally who given answer is mad I have checked all the points nothing is the issue!

No I'm not. I never used it.

I'm sorry, I thought you had tried it out and hated it and switched to Linux after that. I must have remembered your story wrong. Well, neither have I tried Windows10 infact.

Would somebody who had expert Windows10 knowledge please help this guy. IDK, maybe this is not the best forum to ask anyways, maybe Windows10 support is what you really require OP.

I mean, were trying to help you, but most of have a lack of knowledge on modern Windows operating system.

1 Like

For details I have opened one thread here also networking - Ssh client working in windows but not in linux - Ask Ubuntu

No, I had held on to XP long past its expiration date. I dabbled in Windows 7 for a short time but then my hard drive went out- which is what caused me to switch to Zorin OS.

SSH usually is a simple fix, but figuring out what that simple fix is is usually the very hard part. I am woefully unqualified on this topic.


I completely respect your honesty. Now I remember your story, and why in the heck did I forget it, since its practically a copy of my own! Gosh my brain is offline today.

My last Windows experience was Windows7, and I dealt with BSOD's for an entire year on the original installation on that drive, until I jumped ship and moved to Linux. I couldn't take the BSOD's.

Nothing more annoying then when your doing nothing but sitting on a webpage, reading a post on a forum, when suddenly, the computer goes to blue screen.

Yeah, I think the OP might want to think about converting over to Linux full time. But if the OP can't do that for whatever reason, like NAS server only able to use via Windows for example, ok fine.

But, eventually, just like I had to, your going to have to get onboard with Linux full time. Cause reports have already been coming in about Windows 11. And people are not liking it.

Many don't even upgrade to Windows11 before they come here to us here at Zorin. And those that do upgrade to 11, they arn't on it for very long before they come here.

About the only person I have seen from the Linux community who has supported Windows11 in any actual positive light, is Toss over at Total OS Today.

I couldn't believe all the nice things he was saying about it. I am like, dude, your supposed to be a Linux nerd! Well, not really, not anymore, he converted over to Google Chromebooks. So he's, well, I don't wish to say the word, but you know where I am going lol.

So ya, maybe head over to Microsoft Windows10 support forums, their gonna be super knowledgeable about their own OS to help you OP. And again sorry we weren't able to help you further.

I did what I could on my end, sorry to say, it was less then stellar. :cry:

Ok thank you so much for your help but I think you didn't even understand my question literally it's not about windows its about linux only I am trying to connect to ssh client and you are telling to go to microsoft forums.

However you are allowed to lock or close this thread whatever and Thanks for your precious time.

It is best to leave it open so that those using SSH on Zorin OS and are more knowledgeable on the topic may assist you.
I know your title says "urgent" but I am reasonably confident that any effort I made to try to help you would just create more confusion.


And please let me clarify. In no way, was I ever trying to be disrespectful in my posts to you. I really wanted to help you, but I have a lack of knowledge, and so does Aravisian it seems. We really wanted to help you but couldn't. Its most certainly NOT because we didn't want to help you, its not for a lack of trying to help.

We have an awesome support team, but were not all developers here. Developers/programmers have greater skills and know more. And we could really use some more of those on our team. So that if we run into a situation like this again, we will at least have some people on the team who can help.

Again, I greatly apologize that we were not able to help you with this situation. Hope you understand. And I agree with Aravisian, we need to keep this thread open.

1 Like

Maybe @AZorin or @zorink can help with this ?

If either Zorin is available and willing to help, that is a fine thing.
However... We usually try to encourage Community Support as much as possible so that the two members of ZorinGroup can focus on active development.

1 Like


You also tried this ?

1 Like

Just to check to see if the destination is reachable from Linux,
you could try this in the command line.

ping xxx.xxx.xxx.xxx <- IP address

1 Like

I think he/she gaved up and left the area :joy:

Firstly read the thread once please as I am talking about SSH CLIENT not ssh server please try to understand.

Yes it is I already checked thousand times.

No never :slight_smile: It's something about my work so I can't stop working.

I started to wonder if port 22 is blocked.
Have you tried this command in terminal in the destination system?

sudo ufw allow 22