Very big space eater

when i install zorin as minimal, i got 101gb space, but after install netbeans, qt creator, pycharm, sql db browser, android studio, i got now 60gb space. My question is all this software get 40gb ? my ssd is 120gb.

The way you install that software really matters. If you chose snap or flatpak, each package is about a gig, if not more.

Android Studio has the SDK, which is a gig by itself (and constantly increasing in size).

Zorin Core/Lite uses the gtk video libraries. When you install anything qt, you have to include all of the base qt libraries (which your system doesn't have by default). If you install that software by snap or flatpak it will easily make that app several gig.

Log files are created and have to reach a certain size or age before they are overwritten by the system.

Any snap or flatpak apps, find an alternative way to install them (terminal commands using apt or a .deb file) which will greatly reduce the size consumed since they use the system libraries and aren't prepackaged with what's necessary to run the software. This should release about half of that space, if not more.

4 Likes

You may reinstall these programs via the terminal amd use apt if you did not. I would also suggest upgrading yourself with an extra HDD.

So how to recover this space? Those applications should take not more than 20gb. But it takes above 40 gig. How to recover this space? How to remove all completely?

Please open a terminal and run

sudo apt clean && sudo apt autoremove

Please also check if there are log files in root taking up extra space.
Here is an in-depth guide on examining space-hogging logs:

2 Likes

You can use snap list, in the terminal, to view the packages that are installed that way. Use a search engine to find alternatives to snap install for those packages that are installed by snap.

You can do the same for flatpak (flatpak list).

2 Likes

my flatpak list is

Name Application ID Version Branch Origin Installation
Android S… com.google.AndroidStudio 2021.3.1.16 stable flathub system
PyCharm-C… …rains.PyCharm-Community 2022.2.2 stable flathub system
WhatsApp … …imbrero.WhatsAppDesktop 1.2.2 stable flathub system
Qt Creator io.qt.QtCreator 8.0.1 stable flathub system
NetBeans org.apache.netbeans 15 stable flathub system
Freedeskt… org.freedesktop.Platform 21.08.15 21.08 flathub system
Mesa …top.Platform.GL.default 21.3.9 21.08 flathub system
Mesa …top.Platform.GL.default mesa-22.1.7 22.08 flathub system
nvidia-47… …rm.GL.nvidia-470-141-03 1.4 flathub system
Intel …op.Platform.VAAPI.Intel 21.08 flathub system
Intel …op.Platform.VAAPI.Intel 22.08 flathub system
openh264 …sktop.Platform.openh264 2.1.0 2.0 flathub system
openh264 …sktop.Platform.openh264 2.1.0 2.2.0 flathub system
Freedeskt… org.freedesktop.Sdk 21.08.15 21.08 flathub system
Freedeskt… org.freedesktop.Sdk 22.08.2.1 22.08 flathub system
ZorinBlue… …tk3theme.ZorinBlue-Dark 3.22 zorinos system
ZorinBlue… …k3theme.ZorinBlue-Light 3.22 zorinos system
ZorinGree… …k3theme.ZorinGreen-Dark 3.22 zorinos system
ZorinGree… …3theme.ZorinGreen-Light 3.22 zorinos system
ZorinGrey… …tk3theme.ZorinGrey-Dark 3.22 zorinos system
ZorinGrey… …k3theme.ZorinGrey-Light 3.22 zorinos system
ZorinOran… …3theme.ZorinOrange-Dark 3.22 zorinos system
ZorinOran… …theme.ZorinOrange-Light 3.22 zorinos system
ZorinPurp… …3theme.ZorinPurple-Dark 3.22 zorinos system
ZorinPurp… …theme.ZorinPurple-Light 3.22 zorinos system
ZorinRed-… …Gtk3theme.ZorinRed-Dark 3.22 zorinos system
ZorinRed-… …tk3theme.ZorinRed-Light 3.22 zorinos system
KDE Appli… org.kde.Platform 5.15-21.08 flathub system
QGnomePla… …ormTheme.QGnomePlatform 5.15-21.08 flathub system
QtSNI …kde.PlatformTheme.QtSNI 5.15-21.08 flathub system
KDE Softw… org.kde.Sdk 5.15-21.08 flathub system
QGnomePla… …nomePlatform-decoration 5.15-21.08 flathub system
DB Browse… …tebrowser.sqlitebrowser 3.12.2 stable flathub system

IS THAT TAKE 40> GB OF SPACE ? my ssd is 120gb, file manager show 117.4 gb and 72.1 gb free. how to recover that space? should I remove all softwares and reinstall it as apt command? I have installed a minimal version.

That was just flatpak, and i didn't see any packages you just installed. That was mostly flatpak versions of system files for Zorin OS (theme and some sdk's).

Do the same for snap in terminal and you are looking for the names of the software you installed. Any that show up should be searched for an installation method alternative to snap. Once you found an alternative installation (compiling, .deb, apt command), remove the snap version and install by the alternative method.

continuously eating memory.


why two are different ?

I see very little difference between the two.

Have you tried clearing out your logs?

journalctl --vacuum-time=10d

Check your space usage after running the above command and relay if there is a difference.

difference about 6gb is it small?

I see your point.

I was looking at the available space - which you see is the same: 117.4gigs.

All OS's, it doesn't matter which one, will reserve space for temporary files and the like. I do not just mean those in the /temp folder. This includes all on-the-go writes and rewrites.
While 6 gigs is not insignificant... these days... Well, gigs are getting smaller, just like the world.
On read shows the actual space and the other accounts for reserved space.
But both show the same available space.

I understand. is it possible to free up? please suggest I free up unnecessary space because my space is small. I am afraid of continuously eating spaces. Windows use fixed space for installing software. In fact, it doesn't show the exact space value in the file manager. How to determine how many spaces are free? I am sure it takes some unnecessary space may be downloaded files from flathub. where is the location of the downloaded file using flathub?

Usually, space getting filled swiftly is due to System Logs being over-filled.
It is not normal for it to happen and it means that something is wrong enough that it keeps filling ysstem logs.
Have you tried:

journalctl --vacuum-time=10d

hasibul@hasibul-S551LN:~$ journalctl --vacuum-time=10d

Vacuuming done, freed 0B of archived journals from /run/log/journal.
Vacuuming done, freed 0B of archived journals from /run/log/journal/4b7afb2210934fc5a8a393c385b4e01a.

my question is where is the space goes? where is the location of temporary downloaded files? I mean maybe it is store original file after install.

It is not normal for it to happen and it means that something is wrong enough that it keeps filling ysstem logs.

you got the problem. I am using stacer but it makes free only about 1gb of cach.

The above pic shows 117GB of the total, so 117−44 should be 73GB free, it is ok, but it not showing. Here is my problem. please give some suggestion. thanks for your help man.

What about the size of /var/log?

ls -lSsh /var/log

Let's check your disk totals:

df -h

Maybe I found the problem.
hasibul@hasibul-S551LN:~$ df -h
df: /run/user/1000/doc: Operation not permitted
Filesystem Size Used Avail Use% Mounted on
udev 3.6G 0 3.6G 0% /dev
tmpfs 740M 9.9M 730M 2% /run
/dev/sda2 110G 45G 60G 43% /
tmpfs 3.7G 0 3.7G 0% /dev/shm
tmpfs 5.0M 0 5.0M 0% /run/lock
tmpfs 3.7G 0 3.7G 0% /sys/fs/cgroup
/dev/sda1 96M 6.9M 89M 8% /boot/efi
tmpfs 740M 160K 740M 1% /run/user/1000
/dev/sdb1 932G 555G 377G 60% /media/hasibul/WD_BACKUP

How to delete this tmp file?

This is the line we want to focus on.
Can you open your App menu and type disk
It should offer Disk Usage Analyzer.
Launch it - it will be a wait... it can take quite a while (Though shouldn't be longer than about 15 minutes) for it to run
Then screenshot or post the output here.