View all shortcut bindings / Disable Ctrl + Shift

Vs code (and other editors) does not recognize the shortcut Ctrl + Shift + P to open the palette.

It works with Right Ctrl but this is not as practical as Left Ctrl.

From what I researched, it could be an Ubuntu problem.
Reference: OS keyboard shortcuts conflict with apps keyboard shortcuts in GNOME 3 - Ask Ubuntu

Question, is there somewhere to see all configured shortcuts?

I need to disable Ctrl + Shift which must be used by something.

I've looked in Settings -> Keyboard but there's nothing there using Ctrl + Shift.

The switch keyboard layout are also not using these shortcuts.

Gnome 3 is no longer in use. It is now Gnome shell. Think Zorin 17 uses Gnome 42 or 43, can't remember. This guide should help:

1 Like

As you found out, keyboard shortcuts are under Settings -> Keyboard. But I wonder if perhaps you've changed something in VSCode specifically, you can check with Ctrl+K Ctrl+S.

On a fresh install, it works fine for me:

Thank you for the suggestions.
With gnome tweak I couldn't find a replacement that would eliminate the problem.

I'll try with input-remapper.

1 Like

The VSCode configuration is correct, is a new installation, with no changes to the shortcuts made.

This also occurs in CudaText, which has the same combination to open the palette. Ctrl + Shift + P.

Somewhere gnome is using Ctrl (left) + Shift for some event, and this way this sequence is not processed by applications.

Just found this:

Thanks.

F1 can also be used. It works on VSCode as in cudatext.

I will use this shortcut instead of trying to solve.

I believe there must be some other application that is using the shortcut Ctrl + Shift + P globally. But not being able to locate which one it is.

You could try to change the keybinding to something else, just to see if it works that way. Then, change it back to the default. No idea if this would make any difference at all, but if the new keybinding also doesn't work that may be an issue with the program itself.

1 Like