VirtualBox uninstall problem

Hi folks,

Can anyone advise me how to uninstall VirtualBox? When I check in Software there is a tick in the installed box, so I click on VirtualBox and then in the next screen I click on Remove. All I get is an error message, see the screenshot:

You can see that it says installed here:

Can you try typing the command below into your Terminal Ctrl + Alt + T:

sudo apt-get remove virtualbox

I would also advise you to install Synaptic Package Manager instead of using the Gnome Store.
To install Synaptic Package Manager, type the command in yout Terminal Ctrl + Alt + T:

sudo apt install synaptic

Hi Kedric,

OK, I just tried as you suggested and got this message:

So, is it OK to run the command it suggests? I have no idea what it means....

It looks like your installation was interrupted (bad network connection?) and you have some broken package which prevents uninstallation.

Just type
sudo dpkg --configure -a

and try again.

Well, if I were a Linux user of even simple understanding I might take you up on that. Unfortunately I am a clean faced Linux newbie so none of what you have said means much to me and I am very reluctant to start installing things which I know nothing at all about. I appreciate the suggestion but I'm just not close to that stage yet.

Should he fix the installation? Will sudo apt-get --fix-broken install fix the installation? If it fixes the package, then uninstall with sudo apt remove virtualbox?

I think to properly remove the app, it has to be installed properly beforehand.

@Rory Did Virtual Box work? Did you start the application? Is it a broken package, did you get any errors? If it's broken, we can help you to fix it.

This website seems useful, How To Fix Broken Packages In Ubuntu via Terminal

Hi FrenchPress,

OK, I tried that and it ran and then I get this:

Which is what I got, in a different screen pop up, after I ran the Software Updater and it updated VirtualBox. Which I though was fair enough as the stuff in Software Updater is approved by Zorin, right?

But I'm not going to allow anything like third party drivers and UEFI Secure Boot in the same sentence at this stage of my two week old Linux experience. Too scary without knowing what's going on.

How do I get out of this UEFI Secure Boot message without accepting 'OK'?

Maybe try disabling secure boot in your bios? That's the only suggestion I have.

Now I see the problem.
While it is possible to use Secure boot for Linux installation, it is not recommended. Especially if you are beginner, it is better to disable it.

I have been using Linux over 10 years without secure boot and never experienced any security related issue.

I think other members of the forum @Aravisian @Storm @tomscharbach can also attest my statement.

Hi Kedric,

I haven't used it. I just ran the Software Updater, as I do every time I log in, and it suggested the update, so I ran it and then got the UEFI Secure Boot message you can see in my previous post. I couldn't find a way to get out of that so I simply rebooted.

The problem is that everything has been fine with Secure Boot enabled up to now and I only got this message after updating VirtualBox.

I prefer to keep Secure Boot enabled as I have a dual boot system with Win10 & Zorin.

I would prefer not to, it's a dual boot setup with Win10. I'd really like to get rid of VirtualBox as it's only after I updated it that this problem arose.

Since I've never enabled secure boot myself, let's hope other volunteers to pitch in to give you an advice for that.

Fair enough and thanks for pitching in to help though :slight_smile:

Secure boot does not protect Windows or Linux from online threats.

Secure boot protects Windows from the user.

You can absolutely safely disable Secure Boot and I highly recommend that you do so.

1 Like

What secure boot does what? Protect Windows from the user, does Microsoft think we are dumb?

1 Like

You've got a picture :wink:

1 Like

When I was running Ubuntu (2006-2017) Secure Boot was enabled. Ubuntu supports Secure Boot. When I cut over to Solus OS in 2017, I disabled Secure Boot and have had no problems with security issues relating to Secure Boot. However, I am very careful about what I install and how I install it by nature, so I'm probably not a good source for information.

I agree. Windows and Linux security ecosystems are quite different. While I don't think that Secure Boot is critical for Linux builds, I insist that Secure Boot be enabled on any computer running Windows 10/11, because Secure Boot is an integral part of the Windows security ecosystem. That's one of many reasons I don't dual boot.