Vivaldi Web Browser Opening Very Slow

Just got my new Logitech K380 Bluetooth keyboard so I tried it here first of course then tried it on my dual boot with Win 10 ..... first thing I noticed is that when I opened up Vivaldi it just took a few seconds to open where as with Zorin it takes about one full minute ..... it first started doing this several weeks ago .....

I searched the web with no results and contacted Vivaldi support with about the same thing .... someone suggested I open a new profile but when I did that no matter which profile I chose the exact same thing happened .... so that wasn't the answer ....

I know 60-sec doesn't sound like a long time and maybe I'm expecting to much but it is a PITA especially if you close your browser more that once .... and besides it didn't used to do this ....

Just posted this in case someone else has this problem or has a solution .... and no I will not use another browser ..... but thanks for asking ..... :grinning:

1 Like

Maybe try clearing cookies and cache?

3 Likes

Could there be a common problem with Chromium-based browsers?

3 Likes

As I don't use Vivaldi I simply copied, pasted and searched your post's title :smile: and found many results, though I didn't read them :neutral_face:. Looks like I could increase Firefox performance a bit enabling Use hardware acceleration when available, you should see if you have this feature.

1 Like

Please forgive my forgetfulness, but you have how much ram? Depending on the number of extensions (built in or added) as well as what other programs are running (and cinnamon is lighter than gnome, but will still use so much ram) you have two options... upgrade the amount of ram to the max recognized or decrease the amount of time that the paging file is utilized.

Clearing cache and data may help, possibly even turning off or Uninstalling unused extensions could also speed things up. Have you installed prefetch?

2 Likes

I'm running 16g of RAM ...... my history is set to clear daily (which is another suggestion from the Vivaldi forum) .....

What is prefetch ????? ...... also it loads very fast on Win 10 ..... I'm gonna try Gnome next just to make sure it isn't something in Cinnamon .....

Well the same thing on Gnome ..... I thought it would be but had to try ..... :slightly_smiling_face:

1 Like

Gday @Frog , As it's been slowly happening/getting worse,, maybe try a system freshing up like,,
Try, " sudo apt-get autoclean && sudo apt-get autoremove " ,,,
Then run, Update & upgrade, then reboot,

If no good then try restore?
or open firefox ( my fav) sync all your info over to firefox,
Then uninstall the browser & install again, then sync info back.
Good luck.

2 Likes

Thank you sir for the suggestions ..... but it hasn't been getting worse it just suddenly took almost a full minute to load and once loaded it works fine ..... I might also add that when I play a game on Steam it loads immediately without my browser being on ......

The one thing I don't like about Vivaldi is that you can't transfer any of your saved passwords to any over browser or even save them to a file ...... you have to reinstall them one by one ..... they used to have a way to save them but as of about 3 years ago that no longer works .....

Gonna try that suggestion and see if that will work .... I'll report back .....

1 Like

Is opening the browser start after boot-up the issue, or at anytime ? ( can you try waiting 5min's after boot-up, & will the browser open normal?)

I was just referring to it as getting worse, as " It's been happening for awhile"..

Yes i think that happened on windows OS , when i transferred across from W/Explorer to Firefox,, everything transferred , But NOT the saved Passwords, i assume due to encryption. Keep us informed :smile:

1 Like

Each and every time I open the browser it takes the same length of time 1 minute ....

1 Like

First question pops up in the mind:

Did you install Vivaldi as a Snap or as an apt-client on Zorin ?

sudo snap list

and see if Vivaldi is among the Snaps of Zorin.
If so, sudo snap remove vivaldi and install Vivaldi through the PPA --apt-client
But, of course, you need to check this first.

1 Like

No I downloaded it from Vivaldi I believe as I have no Snap packages installed I don't use Snap ....

Thanks

A loose .deb can install as Snap. It is a PROTOCOL not something you like or choose. That is the whole point behind SNAP.
But if you don't check your terminal, no problem for me.

"Zorin the total different way ..... lol "

Ok Snaps can't be the reason on your system. But did you purge snapd in the right way ? That is just one small question upfront. Zorin 16.2 is installed with a Snap-enviroment standard (just as Ubuntu 20.04 b.t.w. )

I would open Vivaldi once more and check in the settings for 'hardware accelleration" and turn that setting to off. (No accelleration thus)

Reboot and see if Vivaldi has now an improved startup time.

3 Likes

You sir win the blue ribbon ..... that was exactly the problem ..... thank you so much for your suggestion .....

4 Likes

Yes, sorry, when I told you to check about hardware acceleration on my first message I couldn't know if it was disabled by default so I suggested trying to see what changes between enabling and disabling it, according to its status. As I read somewhere, performance increases when enabled but can also decrease performance if your specs are weak.

1 Like