VLC with Zorin OS 17

Trying to use VLC with Zorin OS 17 Pro and Core. This app worked with my networked movies in all flavors and updates of Zorin 16. With Z OS 17, when I select a file in the default file manager, I get:

Your input can't be opened.
VLC is unable to open the MRL

If I move the movie over to my local drive, it plays fine. If I use the default video playback app in Zorin (Videos) it will play via the network about 95% of the time.

Not sure what I am doing wrong, but it is doing it on the Pro machine (an I5 Mac Mini) and two ibm laptops.

I can point to the files using file manager without problems, and read the properties of the selected files. I can also select the file I want and move it (in either direction) to my local hard drive -- and then it plays fine. All files are in .mp4 format in Quicktime containers.

Many thanks!

Hi, and welcome!

If you installed VLC from the Software Store there's a good chance that the package format you downloaded is Flatpak as that seems to be marked as the default. Long story short, open the Software Store and search for VLC and see which source is ticked for you:

If it's Flathub as in the screenshot, uninstall it and re-install but choosing the "Zorin OS" option instead.

1 Like

Thanks for getting back to me with your suggestions!

For me, the Flatpak and APT version behave the same -- both for local files, and files located on my lan.

Local files -- always play fine
Network files -- always result in the "Your input can't be opened."

Any other suggestions? I will keep playing with it, and use the "Video" app in the meantime. I don't think that I can use Video across my user base however, because of other limitations.

Have you installed or setup the Samba server? I know that the file manager has this ability by default which explains why you can access files through it, but other programs may be having trouble.

What is the output of the following command when run on a Terminal window:


Here's the results from LSBLK

jim@jim-ThinkPad:~$ lsblk
loop0 7:0 0 63.9M 1 loop /snap/core20/2105
loop1 7:1 0 40.9M 1 loop /snap/snapd/20290
loop2 7:2 0 40.4M 1 loop /snap/snapd/20671
sda 8:0 0 223.6G 0 disk
├─sda1 8:1 0 1M 0 part
├─sda2 8:2 0 513M 0 part /boot/efi
└─sda3 8:3 0 223.1G 0 part /
sdb 8:16 0 238.5G 0 disk
└─sdb1 8:17 0 238.4G 0 part /mnt/ata-SATA_SSD_21011225600183-part1
sr0 11:0 1 1024M 0 rom

I do not recall setting up the Samba Server when I installed Z-os 17. My networking, between my Zorin machines worked fine, and they even connected to the Windows 10 boxes. I am even connecting to my internal IPTV server through the browser without any problems.

I did re-try installing VLC off the Zorin OS repository a short while ago. I noticed that it was installing VLC 3.0.16, vs 3.0.19 which was installed this A.M.

Version 3.0.16 works fine -- no problems whatsoever, in both Zorin 17 Core and Pro.

Thank you for your help. It is much appreciated.

The difference in versions is explained by the difference in package formats; Flatpaks are usually more up to date in that regard. Normally, I prefer the native .deb package (what shows as "ZorinOS" in the screenshot above) but since we've already ruled this out as the cause of the issue feel free to use whichever works best for you.

As for the issue at hand I suspect that the file manager, while able to read files remote, it does so using its own internal libraries to communicate with other servers.
By the way, just to be completely sure, I assumed based on the error you shared in the first post that the remote files are on a Windows machine? And you are able to access them via the "Other Locations" shortcut that appears in the file browser, correct?

If yes, let's try to mount those remote files directly in your file system. "Mounting" here means manually specifying where in your file system you'll have access to these files, which should hopefully solve the problem.

First, install the utility that will allow the system to understand the SMB protocol:

sudo apt install cifs-utils

Create a specific location in your filesystem to mount the files. For example, a new folder called "remote" inside your default "Videos" folder.

mkdir -p ~/Videos/remote

And then proceed with the mount:

sudo mount -t cifs //<windows_hostname>/<path_to_share> ~/Videos/remote -o username=<windows_user>,noexec

Where windows_hostname is the name or ip address of the Windows machine, and path_to_share is the location on that server of the folder that is being shared. windows_user is the username on that machine. The noexec option is simply to prevent executables from running in your system as a security precaution. For video files this is fine.

This would also be a good time to check the firewall settings. I think by default it comes disabled anyway but launch the Firewal Configuration and double check. If it's enabled, add a new rule for SAMBA:

If it works you'll now be able to navigate to ~/Videos/remote and see the remote files there as if they were part of your hard drive. Which you could also do before but now they should be made available to all programs.

For reference:



Thanks! It's working now!

Great! :slight_smile:

Just a quick question, did you have to add any firewall rules at all? And a couple of notes:

  1. You can obviously use whatever location you want other than ~/Videos/remote.

  2. This process works for the current session meaning that you'll have to re-do it on every reboot. If you prefer to have it done automatically when you power the computer:

    A. Create a new file called something like smb.cred and include the Windows hostname, username and optionally user password in the following format:


    B. Save the file and place it in a secure location such as /etc/samba. Make sure you also assign ownership to the root user with proper permissions by running:

    sudo chmod 600 /etc/samba/smb.cred

    C. Add the following entry at the end of the /etc/fstab file. You will need root privileges to edit this file, but this command should do it as well:

    //<windows_hostname>/<path_to_share>  /home/<your_username>/Videos/remote  cifs  credentials=/etc/samba/smb.cred  0 0

    Again replacing the details for your network host. Note also that this time you must specify the full path to where you want to mount this file.

Is important that this mounting location already exists in the system. If you accidentally use a location that contains files they will not be available, but don't worry, they won't be deleted. All you need to do is unmount this drive to access them again.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.