VNC - cannot access my zorinos from a mac

Hi, I am trying to access my ZorinOS desktop from my Mac. I set up vnc sharing (settings>>sharing). On my mac I tried a couple of things but couldn’t get it working

  1. In finder, tried connect to server option and typed vnc://nameOfMyComputer that was given to me when I set up the sharing in zorin. When I try that I get a message:
    The software on the remote computer appears to be incompatible with this version of Screen Sharing.

  2. I tried the same address in RealVNC client on my mac. Didn’t work either.

I also tried changing to an ip address in both apps.

Can someone recommend how I can vnc into Zorin from a Mac? I’d prefer an open source solution. Is there a simple server that I can set up that may work better than the one that I assume ubuntu provides?


Same here. . Thank you!

In searching for answers to this, I came across this Older Thread from several years ago on Ubuntu 14.04:

And found this very similar thread for Ubuntu 20.04:

Definetly seems a common element, here- the encryption.

Looking further, found this Guide:

I have never set up VNC, so I lack direct knowledge, but hopefully some of these resources can help get you moving in the right direction.

If VNC is not working, try accessing Zorinos from a MAC remotely using tools like logmein or R-HUB remote support servers. These should work.

1 Like