Wake to Lockscreen - Computer Notifications

I like using Zorin and Zorin Connect. I have been able to figure out how to manage this amazing OS mostly on my own with minimal Linux experience. Thank you.

My issue:
Lock screen constantly waking due to Zorin Connect notifications.

  • I realize I can turn off notifications in BOTH 'Settings' and the individual Zorin Connect radio toggles.

My question:
I want to know how to change what wakes the computer. Specifically, which applications and their notifications are allowed to send this wake command.

Disclaimer: New to Linux and Zorin in general. Be kind.

You can view which devices have the Wake ability with nano:

sudo nano /proc/acpi/wakeup

Or GUI by opening file manager and navigating to /proc/acpi/wakeup and opening with a text editor.
PWRB is Power Button and the EHC- or Mouse...
You might paste your 'wakeup" file results here and see if you have anything additional in it.

I won't @ you for this because I won't be able to fully get into digesting and testing your suggestions for a short while; but still wanted to...

Thank you for your time and I will make sure to post the results of test as soon as is feasible.

1 Like

Checking in from Mobile so forgive any auto-corrects here...

Normally I wouldn't do this but I won't be testing soon since my computer boot looped after disabling Mobile Devices in the tray to Off.

I did this once I found out that Zorin Connect errors were causing 'indefinite' growth of my syslog file.

The only reason I know this is because I woke up today to find notifications from disk usage manager that my entire drive was out of space.

~333.8GB syslog.1 file. Only after finding this info was I able to put together that Zorin Connect was the thing keeping it open and unclearable by erroring out. At this point is when I tried turning off Mobile Devices down in system tray before even fully recording the error that was occurring. Boot loop :disappointed:

In process of trying live os "rescue".

Anyway.

Edit: @Aravisian the following error was the return of the syslog last majority of errors in the syslog.1
"[Date],[Computer], org.gnome.Shell.Extensions.ZorinConnect[1947]: #0 5591adc176a0 i /usr/share/gnome-shell/extensions/zorin-connect@zorinos.com/service/daemon.js:726 (39cc1bd84920 @ 971)
[Date],[Computer], org.gnome.Shell.Extensions.ZorinConnect[1947]: = Stack trace for context 0x5591adbf01a0 =

I'm pretty sure that's what was in my terminal window before the boot loop.

BTW any quick advice on restoring my system? I can access the files while using Live OS try mode.

I would clear out /var/log/
and remove zorin-connect

sudo apt remove gnome-shell-extension-zorin-connect

If you are feeling adventurous, you may try reinstalling Zorin-Connect to see if that resolves the growing log file...

Thank you.
Can you please advise how to clear out this log folder safely while only being able to boot to the USB Zorin demo-mode?

Currently that is the only way I can locate find the massive syslog file. But while running the clear command within the folder the message returns saying I do not have proper permissions.

I ran sudo cat /dev/null > /var/log/syslog

Also I feel I should note that the massive file's name is syslog.1
The syslog file without the .1 extension is only 138MB.

If easier, I would almost prefer advice on being able to re-boot into the filesystem so that I can run the sudo command while inside own root.

Please bear in mind that I have extensive computer experience but little Linux experience. I came to Zorin to escape M$.

Thanks again.

You might try it graphically.
In LiveUSB

sudo -i

nautilus

Then navigate to the file and right click to try removing it.

What happens when you try to boot?

It's a boot loop of the manufacturer logo before it even transitions to anything else. Keeps flashing on and off.

I see. Yes, this is because root is filled, no room to write to /tmp...

Using sudo -i nautilus I was able to (I think) delete the 333GB syslog.1 file in /var/logs

I rebooted LiveUSB and it still loops.

You mean you rebooted without LiveUSB, right?
Can you boot into the Recovery Menu:
https://www.maketecheasier.com/boot-recovery-mode-ubuntu/

Advanced Options for Zorin
Recovery
Then drop to the Prompt

Clean:

sudo journalctl --vacuum-size=100M

restart the log service:

sudo systemctl restart syslog

Do some more cleaning to free up space:

sudo apt clean && sudo apt autoremove

Ensure package integrity

sudo dpkg-reconfigure -a

Exit out of the Recovery Menu and try booting normally.

-a unknown option. Command failed. Contextual to specify a package name? Is this a reconfigure like a chkdsk? Or a generic cache clear?

Anyway that is the last step I'm on, unsure if should skip.

Thanks again for your help.

Sorry... I mistyped out of Old habits...

sudo dpkg --configure -a

You are a Saint.
Bravo Applause GIF by AS Saint-Étienne

I have fully booted to Home as it was before discovering the syslog and boot loop as well as recovered all that space.

I know it turned into a lot but thanks for staying zen.

2 Likes

Marked Solution. 297

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.