What is the default bluetooth manager in Zorin OS 16 Core. Is it safe to uninstall it?

So I installed Zorin OS today and have been really enjoying it so far (I might just stop distro-hopping now), but there is one problem which I'm facing and that's with bluetooth.

Basically, my computer has Realtek hardware for wifi and bluetooth. Now the wifi card is terrible with linux. It simply doesn't work. The bluetooth is slightly better in the sense that I can use it to connect to any devices and everything works fine, but the catch (strangely) is that I can only get it to work using the Blueman bluetooth manager. I've now installed blueman on zorin and am able to connect to bluetooth devices, but the process of connecting isn't very straightforward. For example, my system can't auto-connect to my bluetooth device (earphones), and I need to try connecting multiple times to get it working. I'm guessing it's because the default bluetooth manager somehow interferes(?) with blueman, preventing it from operating as desired. This guess is based on the fact that in an Arch install I have with blueman as the only bluetooth manager everything works seamlessly.

For this reason and the fact that having 2 bluetooth icons in the panel, 1 from blueman and the other, the default one, looks weird I wanna ask if there's anyway to disable the default bluetooth manager and use only blueman.

All help is greatly appreciated. Thanks in advance!

This one should remove the default,

sudo apt-get purge blueman bluez-utils bluez bluetooth && sudo apt-get autoremove && sudo apt-get autoclean
1 Like

A quick note: The O.P. said:

He wants to keep blueman, but disable or remove any other bluetooth management software, fearing that they are conflicting with each other.

2 Likes

As @Aravisian has pointed out in his comment, I don't wanna disable the bluetooth functionality altogether. I'm just looking for a way to disable the default bluetooth manager. But thank you for the reply.

Blueman/bluez is default for zorin. You may have downloaded two versions. Remove both of them. Then reinstall blueman.

1 Like

I only have 1 version of blueman downloaded. But running apt list --installed shows that I also have gnome-bluetooth installed which I guess is the default bluetooth manager, i.e the one that appears when I go to, say, Settings -> Bluetooth. Is it safe to uninstall this gnome-bluetooth package.

You made it easier for me😀
Yes you can remove it,

sudo apt-get remove --auto-remove gnome-bluetooth
1 Like

So I uninstalled gnome-bluetooth today and it seems to make absolutely no difference. I also saw the package libgnome-bluetooth13 listed with all the installed packages, which seems to be relevant. But when I tried to uninstall that, I was asked for permission to uninstall a whole bunch of very important packages including (but not limited to) zorin-desktop-session and zorin-os-desktop. So I didn't go through with the uninstallation. So I ask, is it just the case that gnome simply isn't built to allow users to disable the default bluetooth management software?

That manages tbe default application for bluetooth. Choosing which service will use the bluetooth adapter. Inbuilt with zorin os.

1 Like

Does that mean I just have to live with both bluetooth managers?

A reason not to live with both is also an assumption:

I think "correcting the bluetooth issue" is the thing you prefer to live with, regardless of how it is achieved.

I do not understand what you mean by "not a straightforward process" and that you suspect interference.
Can you provide more detail?

1 Like

Yes. The bluetooth device I'm mainly using are my earphones. Now whenever I connect my earphones to some device, I hear (as a feature of the product) a voice in the earphones saying "Connected". And when I disconnect the thin, I hear the word "Disconnected".

What happens in my installation of Arch, with blueman as the sole bluetooth manager is that the first time I have to pair with and connect to my device using the GUI and this happens without a hitch. I choose the pair option and then the connect option and I'm done. Subsequently, all I have to do is turn on my earphones, and within seconds, I hear "Connected".

What happens in Zorin is this: Without installing Blueman, if I try to connect to my device using the default bluetooth manager it simply does not work. Now pairing is not an issue. But after pairing, when I select my device from the list shown under bluetooth settings and click on the slider to connect, some times the slider moves to the 'on' position and in a few seconds just gets back to the 'off' position. And other times, the slider moves and stays in the 'on' position and the bluetooth manager shows that I'm connected, but in my ears I hear "Disconnected" and I can't even find my earphones in the sound settings section or play any sounds through them.

Now with a combination of blueman and the default manager, pairing is again not an issue (of course, it never was). But when I try to connect, neither blueman nor the default manager can get the job done. When I try to connect through blueman, I see error messages such as Failed to connect: Resource temporarily unavailable or Failed to connect: Host is down and then both blueman and the default manager start to falsely show that I'm connected. The say I'm connected, but I know I'm not because I just heard the word "Disconnected" and I can't play sounds on the earphones even after this. However, after carrying out this exercise, a new option becomes available when I right click on Blueman's systray icon, namely, Recent Connections > Auto connect profiles on <device-name>. When I choose this option, it takes less than a second for my earphones to get connected. Subsequently, when I turn the earphones off and on again, the first thing I hear is "Disconnected". Then sometimes I can still see the Recent Connections options and selecting it can get me connected, but other times the option is greyed out and I have to repeat the process of trying to connect with the GUI to make the option available again.

This difference in how blueman works alone and how it works with Zorin's (maybe Gnome's in general) bluetooth manager is what makes me suspicious of interference.

Note: I've also tested these earphones with Linux Mint 21 which ships with Blueman as the default manager and the experience is consistent with what I see on my Arch installation.

Same experience for me using blueman and Avantree Headphones on Zorin OS Lite.

Can you try:

killall pulseaudio

rm -r ~/.config/pulse; pulseaudio -k

sudo apt install pulseaudio-module-bluetooth

sudo systemctl restart bluetooth

pactl load-module module-bluetooth-discover

And test...
IF no good, please reboot and then test...

1 Like

I just tried to run these commmands. pulseaudio-module-bluetooth was already installed but I reinstalled it nonetheless. But I couldn't successfully run pactl load-module module-bluetooth-discover. When I run it, I'm greeted with the error Failure: Module initialization failed. When I try to run it as superuser I get the following messages:

Connection failure: Connection refused
pa_context_connect() failed: Connection refused

I tried rebooting and then running these commands but the result is the same.

Yes, running as superuser (Root) will cause that on Pulseaudio...

You might try the tigerite bluez:
https://launchpad.net/~tigerite/+archive/ubuntu/bluez5/

sudo add-apt-repository ppa:tigerite/bluez5

sudo apt update && sudo apt install --reinstall pulseaudio-module-bluetooth

1 Like

I'm unable to add the repository you mention due to the following error:

Err:19 http://ppa.launchpad.net/tigerite/bluez5/ubuntu focal Release
  404  Not Found [IP: 185.125.190.52 80]
Reading package lists... Done                        
E: The repository 'http://ppa.launchpad.net/tigerite/bluez5/ubuntu focal Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

My mistake, I really should have slowed down and checked that the maintainer was still active.
I used to use that on Zorin OS 12... before Zorin OS 15 was released which resolved the issue for me.

Please run

sudo add-apt-repository --remove ppa:tigerite/bluez5

sudo apt update

And also

uname -a

Let's check your kernel...

1 Like

Here is the required output:

❯ uname -a
Linux zorinOS 5.15.0-50-generic #56~20.04.1-Ubuntu SMP Tue Sep 27 15:51:29 UTC 2022 x86_64 x86_64 x86_64 GNU/Linux

Похоже проблема в том, что Zorin OS стоит второй системой рядом с Windows или Mac OS. Вы сможете включить bluetooth, запустив демона в терминале: sudo /etc/init.d/bluetooth start

Viewing bug reports (There are several) on this issue:

I wonder if using the 5.13 kernel might work? You can install it, then reboot and tap the esc key to see the Grub menu.
Choose Advanced Options for Zorin and arrow key down to the Zorin on 5.13 kernel option. Then proceed to boot.

sudo apt install linux-headers-5.13.0-48-generic linux-image-5.13.0-48-generic linux-modules-5.13.0-48-generic linux-modules-extra-5.13.0-48-generic

1 Like