Which File Manager to Use

Now that appeared to be easy fix I renamed Thunar Bulk to .... (Drum Roll) to Thunar Bulk and and Bulk Rename to Bulky ..... aaaaaah .... I'm just so talented ..... :smiling_face_with_three_hearts: :sunglasses:

Now, you know how to rename any application name as it appears in the App menu.
This can come in handy sometimes.

I renamed my terminal to "Nuclear Launch Control Panel."

1 Like

It's a very good day when you can learn something new ..... and for me not screw it up ..... :rofl: :rofl:

Now gonna try out your back key suggestion ..... sure hope it works for me as it will eliminate me having to go back to Win 10 ..... :+1: :clap:

1 Like

:sob: :sob:

Well I tried the Back Key suggestion and it didn't work .... as usual the first photo I changed to to 1 but the 2nd photo refused to clear the current name ... it just sat there glaring at me .....

By the way I'm still on Thunar as it won't let me use Nemo unless I delete Thunar again .... not sure if that matters or not .... like I said I have deleted Nautilus also ....

In the screenshot - it is highlighted.
Was it highlighted when you hit backspace? Did you not pound that backspace key and show it who the boss is?

1 Like

Yes it was highlighted .... no I didn't abuse my poor keyboard ... YET

Maybe you should...

I just tested this several times and each time - the save as dialog has the original name highlighted. Tapping backspace before doing anything else worked.
I notice that in trying to replicate your issue it did not work if I tapped backspace while the Save As dialog window was not the Active Window.
That is, if you clicked anywhere else in between, it may have backdropped that window...

1 Like

I'll give that a try I just have to click on the current name to clear the highlighted name ....

So I clicked on the Original File Name and the highlight disappeared but the cursor started deleting the name from right to left .... as evident by the missing bp in the extension ....

That is why you backspace while it is highlighted instead of clicking on anything.

1 Like

I tried that too .... that is the first thing I did was to hit backspace but it does nothing for me in fact now the highlight doesn't disappear .... I deleted Thunar so the only file manager I have is Nemo .... should I reinstall Nautilus .... do you have it installed on your OS .... if you don't I won't worry about it .....

Oh and I changed the name of Files to Nero just so there is no confusion on which FM is running .....

Time to eat lunch so take a break .... pop a cold one if you have it .... :grinning:


Yes, I have nautyless installed.

So do you - since Nemo does not give the Save As Dialog - Nautilus does that.

Oh, I already have.
Dr. Pepper.

Interesting as it doesn't show up in the Main Menu ....

Well that's OK cause I really stuff things up now .... I decided all by myself to remove Nautilus and so I typed .... sudo apt remove --purge nautilus ..... great move Einstein ......

I have just restarted and guess what ?? I now have no Cinnamon or Zorin DE only Xfce ..... it has almost all my Cinnamon apps and settings just on a Xfce DE .... what a PITA .... I have to reset everything from soup to nuts and I'm going nuts trying to navigate Xfce ....

The first thing I tried to do was reinstall Nautilus from the terminal .... sudo apt install Nautilus .... was told couldn't because some packages could not be installed .... went to Sympatic but as told missing packages .....

And so it is now the next day as I type this .... I solved my problem .... just format disk and reinstall Zorn OS from Rescuezilla ..... got it down to a science now 1 hr and 11 mins start to finish .....

Now I can speak from experience ..... even if you delete Nautilus and it isn't showing up in your Main Menu it is or parts of it are still installed ...... if you try to remove that by typing ..... sudo apt remove --purge nautilus .... DON'T ..... unless you want to reinstall Zorin OS .... the main reason I'm tell you folks about this is so you won't do what I did ....

Now before heading back to the original problem I no longer show Zorin or Wayland on my login page .... I assume that Gnome DE is now gone .... how to get it back ?????

Nautilus is more than the GUI File Manager itself. It is also the desktop.
This is true for Nemo as well and on Linux Mint - Nemo-desktop handles the save as dialog.

Yes, Nautilus is more than just the GUI File manager. It is also the desktop... I just got a funny feeling of deja vu.

To the rest:

sudo apt install --reinstall zorin-os-desktop

1 Like

Ha Ha Ha ..... sounds like you have been there before ..... tried to install Nautilus again from the terminal and also the command you just gave me for Zorin OS Desktop ..... it says I have broken packages .... I checked in the Software and Updates / Other Software but didn't see what it was referring to .....

mike@mike-ROG-Strix-G731GT-G731GT:~$ sudo apt install --reinstall zorin-os-desktop
[sudo] password for mike:
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
zorin-os-desktop : Depends: gnome-shell-extensions-zorin-desktop but it is not going to be installed
Depends: zorin-desktop-session but it is not going to be installed
Recommends: folder-color but it is not going to be installed
Recommends: gnome-photos but it is not going to be installed
Recommends: gnome-sushi but it is not going to be installed
Recommends: nautilus but it is not going to be installed
Recommends: nautilus-share but it is not going to be installed
Recommends: zorin-appearance-layouts-shell-core but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Here is what is in Other Software ..... the 2nd photo is only for the last 3 entries starting with the highlighted one ....

Let's try:

sudo apt update --fix-missing

sudo dpkg --configure -a

sudo apt --fix-broken install

1 Like

I get the same message with Nautilus as well as Zorn OS install .....

What is the output of apt list -u?

1 Like

mike@mike-ROG-Strix-G731GT-G731GT:~$ apt list -u?
E: Command line option '?' [from -u?] is not understood in combination with the other options.
mike@mike-ROG-Strix-G731GT-G731GT:~$ apt list -u
Listing... Done
gnome-software-common/focal,focal 3.36.1-0ubuntu0.20.04.1+zorin1+old1 all [upgradable from: 3.36.1-0ubuntu0.20.04.0+zorin1]
gnome-software-plugin-flatpak/focal 3.36.1-0ubuntu0.20.04.1+zorin1+old1 amd64 [upgradable from: 3.36.1-0ubuntu0.20.04.0+zorin1]
gnome-software-plugin-snap/focal 3.36.1-0ubuntu0.20.04.1+zorin1+old1 amd64 [upgradable from: 3.36.1-0ubuntu0.20.04.0+zorin1]
gnome-software/focal 3.36.1-0ubuntu0.20.04.1+zorin1+old1 amd64 [upgradable from: 3.36.1-0ubuntu0.20.04.0+zorin1]
zorin-exec-guard-app-db/focal,focal 1.2.11 all [upgradable from: 1.2.10]