Why does the video freeze when, in a meeting, I try to share the screen?

This has already happened 3 times. It started a little while ago, but it’s annoying me a little.

The scenario is as follows: I have Firefox, Slack and Spotify open. 67% free ram, 31% CPU usage. I try to share my screen on Google Meet and the screen freezes, I can still hear the audio and move the mouse, but nothing else responds.

I had this problem with Google Meet on Firefox and the Zoom app. In the case of Zoom I managed to continue using the computer, but all applications started to fail and the camera did not respond. I tried to shut down and the system returned an error on the dbus, I had to force the shutdown.

I am using Zorin Lite 15.3. My device is a Lenovo S145-15API.

I just ran the updates, I hope it resolves.

I also have another point: since I installed it, it presents some recording errors before turning off, then it turns off normally. I didn’t read the error messages, but they all said something about recording (at an address, perhaps, I don’t remember). This is an intermittent problem; I could update this post as soon as I see this error again.

Try:

  1. See if you can switch drivers under Zorin Menu -> System Tools -> Software Updater -> Settings ->Additional Drivers.
  2. Check your settings against: Software Updater settings

Since the problem is specific to those applications, the above steps may not resolve the issue but they’re worth trying.

I will have to wait, since this error does not happen all the time

Update: I just restarted the system because it “lost control” of RAM or something like this. I had Zoom open (again) on a call while using Firefox when Zoom lost everything it was doing and turned into a gray window with some badly rendered buttons. I tried to close it and the system returned a warning that Zoom appeared to be busy. I forced it to end and went back to Firefox when I realized that Firefox was still working but it had lost reference to the pages that were open.

Note: I sent a photo of the error during shutdown

Edit: My settings match the settings you recommended. I haven’t changed anything since installation


Seems like this writer has the same problem. Aravisian had noted potential kernel issues. Unfortunately, that is not an option here.

Change the amount of RAM Firefox uses (I believe it’s under Edit -> Preferences -> performance or a similar path) and reduce it from default of 8 to 2 or 1 or something lower. See if that helps.

You may try adding “iommu=off” to grub
In terminal, enter

sudo nano /etc/default/grub

Look for the line that looks like:

GRUB_CMDLINE_LINUX_DEFAULT=“quiet splash”

change it to look like

GRUB_CMDLINE_LINUX_DEFAULT=“quiet splash iommu=off”

Hit ctrl+x to exit. Then hit the y key to say yes to save it. Then hit the enter key to save it under the original file.
The terminal will return to normal. You can reboot and test.