Why is most of my screen black and the display only in a chunk of the screen?

Can you give some details to help you. e.g.
What graphics card do you have?
What resolution is that screen?
How is that screen connected to your machine (what ports/cable type)?

gt 1030 low profile *i have the nvidia drivers
and this picture has my internal resolution

it's connected via HDMI

So Zorin Setting is currently 1680x1050 resolution.
Do you know native resolution of the large screen. (i.e. is it a 4k monitor)
Do you see (or have tried) other resolutions from that "Resolution" dropdown.

tried other resolutions and nothing really changed
it's not a 4k monitor it's a pretty mid toshiba amazon fire tv lol

Is it installed or does it run in a Virtual Machine?


Is it just me... or is there a line vertically running just to the left of center of the monitor?

@qwert, what is your terminal output for

sudo lshw -C video

I got this
description: VGA compatible controller
product: GP108 [GeForce GT 1030]
vendor: NVIDIA Corporation
physical id: 0
bus info: pci@0000:01:00.0
version: a1
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress vga_controller bus_master cap_list rom
configuration: driver=nvidia latency=0
resources: irq:30 memory:f6000000-f6ffffff memory:e0000000-efffffff memory:f0000000-f1ffffff ioport:e000(size=128) memory:c0000-dffff

Either using Software & Updates > Additional drivers


Which Nvidia driver are you using?

Is the HDMI cable plugged into the Nvidia card port or into the Motherboard port?

typed that in the terminal and got this
"Failed to initialize NVML: Driver/library version mismatch
NVML library version: 535.161"

That sounds like a Cuda issue.
Have you manually installed any Graphics related packages?

You might try

sudo apt remove --purge '^nvidia-.*'

sudo ubuntu-drivers install

Once done, do a hard reboot fully shutting down the computer before booting back up.

and now everything is zoomed in

Is it still producing the error and the screen only partially populated with a tiny display?

Screenshot from 2024-03-23 14-58-38
it looks like this

and no it's just the whole screen. not a chunk of the screen this time

Opening Display, what resolution are you using?
Or the terminal output of


Does it say something like "Failed to get size of gamma..."?

yep got "xrandr: Failed to get size of gamma for output default
Screen 0: minimum 640 x 480, current 640 x 480, maximum 640 x 480
default connected primary 640x480+0+0 0mm x 0mm
640x480 73.00*"

Can you follow these steps to use the nomodeset grub parameter (Be sure to run sudo update-grub) and then reboot and check resolution?

hard reboot or soft reboot???