Why is Wifi still working if airplane mode is on?

After installing Zorin 16.2, I turned on Wifi and worked as expected - but afterwards I turned on airplane mode, Wifi was still working despite it.

Also how do I turn off both airplane mode and bluetooth at the same time?
When I turn off one thing, the other automatically turns on?

Is there any way I contact the right person or place to do something about this issue?

Gday @Z_123 , As far as i know, "Airplane Mode" should disable both, wifi & bluetooth.
There maybe several reason's for this behavior,
Eg: Bios settings
systems update/upgrade... etc..

Please let us know, how you are running ZorinOS, ( clean, dual boot, usb, etc)
Also what is the pc?
This link may trigger a clue aswell,

I have installed Zorin via USB to a new SSD I have inside my computer.

1 Like

I assume you have just one wifi/bluetooth card?

Try that second link in the post above " Make airplane sane again".
You may also search for that, in relation to Ubuntu OS,,, as ZorinOS runs off Ubuntu setup.

Try these,
https://extensions.gnome.org/extension/4604/sane-airplane-mode/

Keep in mind, After any changes , reboot & try, next step,

Sorry do you have a Desktop or Laptop?
Do you mean a 2nd ssd? or more ?

Also how long has it been since you installed?

Laptop and yes I just recently installed another SSD

sorry my late entry :smile:

About 3 days ago

ok, you my also need a few updates/upgrades/etc.
So first run this in "Terminal"
sudo apt-get update
Then run this,
sudo apt-get upgrade
Reboot :smile:
After about 5min's,repeat again to see if you have more updates?
Next run,
sudo ubuntu-drivers autoinstall
:smile: Reboot :smile:

Note: sometimes updates/upgrades can be slow.

Also do you have windows on the other ssd?

Will this guarantee that I will be able to turn off both bluetooth and airplane mode at the same time?

Yes but that does not matter as they are not connected with each other.

Ok try this, ( it maybe just Knowledge )
first:
Enable both wifi & bluetooth,
Now turn on Airplane mode ( should disable both)
While in Airplane mode, you can enable wifi, not bluetooth. ( Don't ask me why hahahahaha)
If you disable wifi, while in Airplane mode, It will remain disabled , when you turn off Airplane mode.

Old "Airplane Mode" automatically turn both off.

New "Airplane Mode" you can "Enable" wifi at the same time.

Airplane mode is like Mute.

Hope this may clear the air :smile: :+1:

I tried this but it doesn't disable both bluetooth and airplane mode...

Also when I tried to keep Zorin on Airplane after shutting down, it does not stay on airplane mode after I turn back on?

That is because most OS's make the assumption that you want to connect to the internet. There should be a setting to disable wifi at boot.

Can find how to disable bluetooth at boot:

In terms of wifi: