Wi-Fi 6 AX200 not working

Where can I see this?

download via "Software app store" ,,, "cpu-x"
or look on the MB or maybe a receipt

1 Like

Revision - Rev X.0x
Brand American Megatrends Inc
Version - 1003
Date 06/04/2019
Rom size 64kB / 16 MB

1 Like

is it PRIME H310-PLUS R2.0 ..?

Give me a minute

Sorry about this I’m half asleep it’s 2:00 in the morning for me it’s prime h310-plus R2.0

1 Like

So do you think this is going to be fixable since I’ve been on a different Linux distro and it’s doing the same thing?

OK a bigtime yes on firmware needing updating..
looks like ver :2208 is the latest.
Try this


also there are great guides on how to update firmware on that site.
Hope this helps.

1 Like

Thanks would this fix the internet problem or?

It's a good step towards fixing it... /// talk tomorrow.


Definitely get that firmware updated :+1:

Which distros have you tried besides Zorin? Zorin 17 is coming soon, but right now 16.3 is based on Ubuntu 20.04 kernel 5.15.x - which most of the 20.04 fixes / firmware / driver installs, are much the same in Zorin, and should work. Also with other distros, if not stated otherwise - they're using 5.19 or 6.x kernels. If one distro works, it'll be easy to take a look into the kernel to see what version, and what drivers are being used.

But absolutely get that firmware updated :grin: I'll be hanging around for a while so if you need some help on that, I've got the .zip downloaded - I see a .exe, hopefully it's not Windows installer :grimacing:

Pop os I have tried and having the same problem works with kali Linux tho

Okay.. that makes a little sense - Kali is on a 6.3.0 kernel, I can't pin down what Pop is using though, but is an earlier version than what Kali is using - and different.

If that's the case, you could upgrade the kernel for Zorin and have the working WiFi - but I'm researching how to install your BIOS / UEFI firmware, since it's in a .exe.. (edit) okay nvm I'm a stupid lol just need to have an empty flash drive, formatted in FAT32, then take the contents of the .zip from the Asus BIOS download page, copy the .cap file to the USB, reboot into BIOS, then there should be an update firmware option in there somewhere in the menus.

1 Like

So I will have to update the kernel can this cause problems for zorin ?

Normally, it should not. But the best way to know is to try it and find out.

sudo add-apt-repository ppa:tuxinvader/lts-mainline

sudo apt update && sudo apt install linux-generic-6.03


i have installed 6.6.1 internet is still not working

1 Like

I would try the 6.3.0 kernel that you mentioned Kali using and working, 6.6 may not have or include that device support anymore.. If any of them don't work, you can just uninstall them like an app.

What is your output of sudo lsmod | grep -i iwl, another sudo dmesg | grep -i iwl, and I know this isn't going to help you, but this is my card, apparently very close to the one you're using now:

Screenshot from 2023-11-19 14-28-16

And I'd like for you to just double-triple-quadruple check that Secure Boot is definitely disabled. You can check this with sudo mokutil --sb-state​ and within BIOS - do post the outputs of all, that will help a lot, if you can.. And one last thing to post output of is apt search intel-microcode - is it listed as [installed]??

(edit) I was able to find this:

Which has your AX200 chip listed, third in the list - if that driver doesn't work, you may need to use the AX201 driver, as stated here; first reply to the OP:

But, I would try these with the current 5.15.0-88-generic Zorin kernel, before trying any newer kernels and the firmware for WiFi. Then, try with the higher kernel versions installed earlier.

Side note: I didn't see anything about upgrading the BIOS / UEFI firmware for the mobo - was that completed?

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.