Wi-Fi issue

Hello Guys. I am new to Linux and there is an issue with my wifi on a laptop on Zorin. From phone and other devices, the wifi works perfectly fine. But from this laptop wifi is disconnecting and I have to turn off wifi settings and on again each 5-10 mins. Do you guys what might be issue?

Hello and welcome to the Zorin Forum! It's always GREAT when newcomers arrive as it helps in the growth of the community as well as helps us all become more knowledgeable in Linux and how to solve new issues that may come to light. Plus assist Team Zorin as they work on the next Zorin OS for future users.

Please take the time to use the search function above as well as the Tutorials and Guides to see if your issues has already been addressed before. It helps the Mods and others to focus on new issues as they all do for their love of Zorin and out of their Free time.

Please include when posting your system specs as this helps the Mods and others when assisting you in a resolution to your problem

System specs:

CPU
GPU
RAM
HD
ZORIN OS (i.e. Core Lite Pro )
Make of Computer
Model

here is a couple of links of reasons that may help right now as we wait for info from you

Why does my wireless network keep disconnecting?

Wifi is seriously slow in zorin pro 16

Hello Buddy. I have tried several ways and still, nothing works for me wifi is dropping suddenly and I have to reconnect once in 4-5 min. Thank you for your response.

System specs:
CPU: Intel i7-7700HQ (8) @ 3.800GHz
GPU: Intel HD Graphics 630
GPU: NVIDIA GeForce GTX 1050 Mobile
Memory: 5575MiB / 15878MiB
HDD: 2 terabyte
Lenovo Y520-15IKBN

Can you please post the output of

sudo lshw -c network

*-network
description: Wireless interface
product: QCA9377 802.11ac Wireless Network Adapter
vendor: Qualcomm Atheros
physical id: 0
bus info: pci@0000:03:00.0
logical name: wlp3s0
version: 31
serial: 64:6e:69:df:21:0f
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
configuration: broadcast=yes driver=ath10k_pci driverversion=5.13.0-35-generic firmware=WLAN.TF.2.1-00021-QCARMSWP-1 ip=192.168.0.39 latency=0 link=yes multicast=yes wireless=IEEE 802.11
resources: irq:133 memory:a4000000-a41fffff

This may be a firmware issue. Can you try the Firmware I uploaded here:

Elevate to root

sudo -i

nautilus

Or if using Zorin OS Lite:

thunar

Navigate to
/lib/firmware/ath10k/QCA9377/hw1.0
Rename firmware-5.bin & firmware-6.bin to firmware-5.bkp & firmware-6.bkp

Extract the files you downloaded a moment ago and move them to /lib/firmware/ath10k/QCA9377/hw1.0
Reboot and test.

Thank you for your effort but this problem is still existing. I have done everything that you have mentioned and Problem remains the exactly same

1 Like

Is this a notebook computer or tower PC?

This is a notebook computer

Then you should check if Powersave is inhibiting your wifi.

sudo nano /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf

Change wifi.powersave = 3 to wifi.powersave = 2
tap ctrl+x to exit, then the y key, then the enter key.

Yes, I have done it and it is still the same problem. Don't know what to do.

In terminal, please run:

ls /sys/class/net

Make a note of the wlp... I.D. for your wifi. For this example, I will call it wlp0s0.
Replace all instances below of wlp0s0 with your noted I.D. discovered above.
Now run:

sudo nmcli networking off

sudo systemctl stop NetworkManager

sudo ip link set wlp0s0 down

sudo modprobe -r ath10k_pci

sudo modprobe -r ath10k_core

sudo modprobe ath10k_pci

sudo ip link set wlp0s0 up

sudo systemctl start NetworkManager

sudo nmcli networking on

1 Like