Wi-fi not detected in HP Pavilion ec1019au

I couldn't modprobe rtw89-dkms

Can you please clarify this?

You do not need to modprobe rtw89-dkms.
As above - 8852be is merged into rtw89. So you would modprobe 8852 except that you would only do so if you installed 8852 as a module.

That reply was for @zabadabadoo regarding problem with Wi-Fi on Windows.

I need to issue "sudo modprobe rtw89-8852be" , right?

Oh, I see thanks.

You might try sudo modprobe rtw89pci but realistically, you should not need to modprobe at all in these steps.
Also please note 337harveys post above.

Finally i found someone who has the same problem as mine.
This thread exactly describes what i'm trying to say: No available wifi networks shortly after booting up - #66 by ricklinux - Newbie - EndeavourOS
Yes, wifi comes but goes off eventually after few seconds or minutes with rtw89-dkms.
Looks like they merged the driver but it doesn't work as expected. Can you please tell me where can I raise the issue?

Few logs:

sudo lshw -c network
[sudo] password for mani: 
       description: Wireless interface
       product: Realtek Semiconductor Co., Ltd.
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:01:00.0
       logical name: wlo1
       version: ff
       serial: 10:68:38:c3:2a:2c
       width: 32 bits
       clock: 66MHz
       capabilities: bus_master vga_palette cap_list ethernet physical wireless
       configuration: broadcast=yes driver=rtw89_8852be driverversion=5.19.0-32-generic firmware=N/A latency=255 link=no maxlatency=255 mingnt=255 multicast=yes wireless=IEEE 802.11
       resources: irq:81 ioport:f000(size=256) memory:fcf00000-fcffffff

Note: Above commands prints out IP if connected to internet but by the time I issued the command internet is gone.

inxi -Na
  Device-1: Realtek driver: rtw89_8852be v: N/A modules: rtw_8852be pcie:
    speed: Unknown lanes: 63 link-max: gen: 6 speed: 64 GT/s port: N/A
    bus-ID: 01:00.0 chip-ID: 10ec:b852 class-ID: 0280
sudo depmod -an | grep 8852be
updates/dkms/rtw_8852be.ko: updates/dkms/rtw_8852b.ko updates/dkms/rtw89pci.ko updates/dkms/rtw89core.ko kernel/net/mac80211/mac80211.ko kernel/net/wireless/cfg80211.ko kernel/lib/crypto/libarc4.ko
alias pci:v000010ECd0000B85Bsv*sd*bc*sc*i* rtw_8852be
alias pci:v000010ECd0000B852sv*sd*bc*sc*i* rtw_8852be
journalctl -b0 -p4 -r --grep="blue|wireless"
Aug 03 15:44:50 AMD kernel: Bluetooth: hci0: AOSP quality report is not support>

You sadly may need to consider getting a Wifi USB adapter that is Linux Compatible.

(Side note: This thread is marked as Solved - but the recent posts imply it is not yet solved.)

Hi @Aravisian
Sorry for spamming the thread after I marked a solution.
Of course it solved the problem but it is a work around and there is some work involved every time there is a kernel update.
Sometimes I panic when WiFi cutoff when I just do sudo apt upgrade and then I realize that I need to recompile the drivers and reinstall (if that upgrade involves a kernel upgrade).
Sure, the problem is solved but PARTIALLY.
I'm sure this thread will be useful for the people who buys a laptop with this hardware.

Let this be the last reply in this thread.

1 Like

Not at all. It was me that misunderstood. I had thought that your Wifi was cutting out after a few minutes of use.

Yes - having to reinstall the Wifi Drivers after each kernel upgrade can be annoying. But, there is a workaround for that, too. You can lock the kernel in so that you may upgrade fearlessly.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.