Wifi Airplane Mode activates itself

I have this problem too, but my laptop is Panasonic!

Do you have any solution for me?

My main problem is that airplane mode is keep turning on! And when I used the line that you mentioned in terminal, less that a minute it turns on again.
Also my laptop has a physical key for WiFi.

If the physical switch is not making any difference, it may be that your ACPI tables are not being properly translated. This often relates to how they were written for Windows OS, then never really updated by the manufacturer.
You can use a couple of Grub Parameters to delegate how they should be read on initialization and this should work for either wake from sleep or boot:

acpi_osi=! acpi_osi='Windows 2009'

To add them, let's use the text editor in terminal just for ease and speed:

sudo nano /etc/default/grub

arrow key down to GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" and add the above parameter. It will then look exactly like:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=! acpi_osi='Windows 2009'"

Note the single tick quote marks. Those are important.
Once done, tap the keyboard shortcut ctrl+o to overwrite, then enter to save current configuation, then ctrl+x to exit the editor.
Now, you must run

sudo update-grub

in order for the changes to take effect.

You must reboot, check the physical switch is off... then Reboot again... and test wifi.


Thank you so much for your time.

Unfortunately it didn't work.

I'm considering going back to Win 7 even though that I hate it.

I just want you to know that, going back to Win 7 did not help either.

This may be a hardware issue- the Wifi card itself being faulty.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.