Hardware switch airplane mode

And both the fn key and the f12 key operate normally independently?

A Quick Explanation on Computer Components:
Let’s say you buy a Graphics Card and plug it in and start using it. You see an increase in your graphics abilities- a fine thing. That Graphics card has a processor, memory… Just like the motherboard.
And just like the motherboard, it is Programmed with an Operating System. These operating systems, like BIOS for example, run independently of Windows or of Linux or of MacOS. The graphics card is not the only component that does this and many pieces of hardware are programmed with a system and code.
On any operating system that you use, e.g. Linux or MacOS, the OS of your choice does Not Instruct These pieces of hardware as much as They Communicate With Them. The GPU will tell your Linux kernel what it is Doing… And that is relayed to the xserver for the Xwindow system. This is different from the GPU being instructed what to do by the kernel or by x.
This is also true for pieces of hardware that Plug into the motherboard by ports, such as USB. And it can be true for pieces of hardware soldered onto the motherboard.

I suspect in this case, that the HP component for this function is being affected in this way. Since you started the thread, I have slithered all over several aspects of the web. What I have found is a LOT of people complaining about this to HP and a lot of it is archived. In Publicly viewable spaces, HP Claims it is uncommon. No, it ain’t.
What I suspect is that when Windows did an update, it sent a command directly to the M.B. Hardware code that created the glitch. Since the glitch is in the hardware code, that is the place it must be fixed or addressed.

You might try an HP BIOS or Firmware update, then we can look at the Ubuntu Firmware, afterward…

Thank you very much, great explanation! Yeah that’s what I also found as well about this specific model of HP. I will also try the BIOS update during the weekend. And to answer your initial question, yes they do work independantly.

Then, the hardware is not damaged.

Thanks you again for your detailed information! I just checked to update the BIOS but it seems that it’s already updated to the latest possible version, which was released years ago. So my questions is what should I do now next? I understand that I have to possibly perform an Ubuntu firmware update, how do I go about this?

Try https://itsfoss.com/update-firmware-ubuntu/

I just tried the method as described on the link, it all functions as intended, up until the very last line code. After inserting that, only a new line appears in terminal and nothing happens.

What new line appears?

A clear line for me to enter a new command. Same thing as when you press the enter key when you haven’t written anything in terminal. Does that make sense? If not, I can post a screenshot.

Ah, ok. Yes, it does the same thing on mine if I run it.
It means that it has completed the command; no upgrades available.

Alright, now that the ubuntu firmware update method has also been tried, amd the bios is already in it’s latest version, what else is there left?

Probably some stuff we do not yet know.

In other words, do not lose hope. I cannot count on both hands how often I have seen someone discover a solution right at the brink. Currently, I am at a loss…
And for all we know- A wipe and reinstall of the Operating System might fix it.
But let’s keep researching…

As it stands, we know that anything windows did as an operating system cannot Carry Over onto Zorin. That was wiped clean.
It is possible that a Windows update carried a Firmware update with it and the firmware update is to blame- in which case reverting to an OLDER firmware might resolve- but I do not see that as being as applicable on Linux.

Again, thanks for being so patiently helpful, really appreciate it. Okay that all makes sense, would it perhaps be a good idea to install Windows again and try methods available through that OS instead, before reverting back to Zorin? Or am I misunderstanding things and that wouldn’t enable me to get to the proper settings to possibly fix this?

It’s worth a shot. I’d try it. I do not have enough knowledge to really know.

I’ll try it out to see if it will have some sort of effect or not. Thanks again for your help!

Fwiw, since you’ve already tried Zorin, can’t hurt to try other distros to see if they take care of your problem. Should be a lot faster than reinstalling Windows.

Not a bad idea actually, will do, thanks!

did anything work for you ? I am having a similar problem.

Marked solution. 25

A post was split to a new topic: Cannot control Airplane mode or bluetooth from settings

A post was split to a new topic: Wifi Airplane Mode activates itself