Wifi driver (dlink dwa-182)


I am having trouble installing dlink wifi dongle, dwa-182, on my ZorinOs 16. Zorin does not recognize my wifi adapter at all. Kindly, send my the appropriate driver link to install it.

Hi and welcome to the forum :slight_smile:

You can check Dlink's site.
They offer Linux drivers to some models.

Hi thanks,

Actually, I am very new to Linux. I checked Dlink website yesterday and downloaded the driver for Linux. But it didn't work and my Wifi adapter is not recognized on Zorin OS 16. On Dlink website, the driver was I think for Linux 4.3.2, while I think Zorin Os 16 kernel is 5.11.

Did you check "Additional Drivers" in Zorin?
Mine look like this:

mine looks like this.

Screenshot from 2021-08-28 12-28-42

Could you give me the output of this command in terminal?

Sure, here it is

As far as I can tell from this output, your WiFi dongle is recognized by OS.
What made you to think that it is not recognized?

There is no wifi right at the left bottom of taskbar. Also, on the setting, I cannot see wifi.

Maybe the device is not recognized and the logs you see in lusb command is becuase I installed many drivers since yesterday

bottom right

Screenshot from 2021-08-28 12-45-06

Have you checked this page?

yes I did it all but did not work

I have 2 Dlink wifi adapter, one is dwa-182, another is dwa-120. both do not work on Zorin OS

Interesting thing's that, both of my dlink wifi adapters, when I plug them in and run lususb command, they are both recognized but they are not listed in setting as wifi adapters and not shown on the taskbar

OK, it is now getting beyond my capability.
I will ask @Aravisian to see if he could help you.
He is way more experienced than me when it comes to Zorin OS.

I appreciate. Kinldy let me know

It works now :grinning:
I plug out wifi adapter from the USB3 port on the front of my pc and connected the dongle to usb3 on the back panel of pc and restarted Zorin and it worked. It was really ridiculous :smile:

1 Like

and now, when I plug it on front usb3 ports, it workes as well. I rally do not understand the logic behind it :smile:
anyway, I really appreciate your time and support