WiFi Keeps Disconnecting on Zorin OS 16 Core

As the title goes, my WiFi keeps disconnecting. Upon connecting again it always asks me for the password. I've checked my network. Seems like everything is OK. My other devices get WiFi, as usual, with no problems whatsoever.

Sidenote: I've recently switched to Zorin OS 16 Core. I am using default settings. Haven't changed any network configuration.

Thanks!

1 Like

It sounds like a driver issue to me.
Can you issue this command in terminal
lspci
and paste the result here?

1 Like

Here's the output:

00:00.0 Host bridge: Intel Corporation Haswell-ULT DRAM Controller (rev 0b)
00:02.0 VGA compatible controller: Intel Corporation Haswell-ULT Integrated Graphics Controller (rev 0b)
00:03.0 Audio device: Intel Corporation Haswell-ULT HD Audio Controller (rev 0b)
00:14.0 USB controller: Intel Corporation 8 Series USB xHCI HC (rev 04)
00:16.0 Communication controller: Intel Corporation 8 Series HECI #0 (rev 04)
00:1b.0 Audio device: Intel Corporation 8 Series HD Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 8 Series PCI Express Root Port 3 (rev e4)
00:1c.3 PCI bridge: Intel Corporation 8 Series PCI Express Root Port 4 (rev e4)
00:1c.4 PCI bridge: Intel Corporation 8 Series PCI Express Root Port 5 (rev e4)
00:1d.0 USB controller: Intel Corporation 8 Series USB EHCI #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation 8 Series LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 8 Series SATA Controller 1 [AHCI mode] (rev 04)
00:1f.3 SMBus: Intel Corporation 8 Series SMBus Controller (rev 04)
01:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 10)
02:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8723BE PCIe Wireless Network Adapter
03:00.0 3D controller: NVIDIA Corporation GM108M [GeForce 840M] (rev a2)

Hello there Capriciousduck! Welcome to Zorin OS 16 CORE! :grin:

Please click here to get driver for your adapter.

1 Like

But on that page, I see that the driver is included in the kernel.

Which is what I would assume too, correct. I am trying to come up with some ideas to aid you with this. I am wondering if power saving features are being automatically turned on for your adapter, Linux is known to do this to conserve power on devices that support it.

Please install this extension, its a power management extension for WIFI adapters.
https://extensions.gnome.org/extension/3258/wi-fi-power-management-toggle/

1 Like

I see that in the iwconfig the power management is switched off.

wlp2s0 IEEE 802.11 ESSID:"LHC"
Mode:Managed Frequency:2.437 GHz Access Point: 00:6D:61:63:68:D7
Bit Rate=72.2 Mb/s Tx-Power=20 dBm
Retry short limit:7 RTS thr=2347 B Fragment thr:off
Encryption key:off
Power Management:off
Link Quality=70/70 Signal level=-26 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:63 Missed beacon:0

Can you do me a favor and type

uname -a in terminal and post the results here. I am now strongly beginning to suspect that you might have the updated kernel, and users have been having loads of issues with that.

For example, if you have the 5.11.27 kernel, your good. But once your on 5.11.34, computers act like their melting down with issues. You might also have issues with the 5.13 kernel too depending on hardware.

If it is indeed true that you are running the newer kernel and its causing issues, we can role back your kernel in the GRUB Advanced Options at boot.

1 Like

Linux i7 5.11.0-34-generic #36~20.04.1-Ubuntu SMP Fri Aug 27 08:06:32 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux

I guess I'm on 5.11.34

To which verison is it good to switch?

Ya, lets see if we can revert your kernel.

Step (1) Shutoff....Then Power On Computer.

Step 2) After 2-seconds, begin holding down the SHIFT key.

Your computer shoot enter the GRUB menu.

Step (3) Select Advanced Options.

From there you should be able to find the kernel override options, choose kernel version 5.11.27, and boot with that.

Once in the system, test your WIFI, see how things go. If you have 0-issues whatsoever, then we will treat that as a success. But your not done yet.

If we don't put a lock on the newer kernerl's, your system will just automatically update your kernel once again, at the next update interval.

If you don't already have Synaptic Package Manager installed, you can install it by typing in terminal...

sudo apt install synaptic

Once installed, launch Synaptic. On the right side of the APP you will see a search function, click on that button. Then in the search field type, Linux-headers. You will get a ton of results.

Easiest way I have found, is to filter the results by version, once done, you can scroll down to the latest versions. To put a lock on the newer kernel versions, select them, then go up to package, and click on lock package.

It will look like this when your all done, then just click the Apply button to finalize the locks.

Put locks on kernel 5.11.34 and 5.13 kernels.

2 Likes

Ok. Will do it tomorrow morning.

1 Like

Hi. I put a hold on my kernel. However, how do I know when it is good to move to the newer kernel?

@StarTreker I'm having WiFi issues even on kernel 5.11.27. What do I do?

Can you try:

sudo modprobe -rv rtl8723be

sudo modprobe -v rtl8723be ant_sel=2

echo "options rtl8723be ant_sel=2" | sudo tee /etc/modprobe.d/50-rtl8723be.conf

Reboot, test.

If the above does not work, try switching to antenna 1:

sudo modprobe -v rtl8723be ant_sel=1

echo "options rtl8723be ant_sel=1" | sudo tee /etc/modprobe.d/50-rtl8723be.conf

Reboot, test.