Zorin Forum

WLAN Speed on Zorin

Hello, my laptop model is Z50-70. Mine has the Realtek RTL8723BE WiFi chip. The thing is I am getting only around 50Mbps even if my internet speed is 100Mbps. I tested the network speed on my brother's laptop (a Macbook Pro) and he gets 98Mbps.

Is there a problem with my chip?

Have you disabled power management yet?

CTRL ALT T to enter terminal.

xset -dpms

I would assume your system has the driver already loaded in the kernel, if you are able to establish a network connection and access the net, so lets start with disabling power management first.

If the above wasn't enough to fix it, you can also try these commands which did work for another user on here...

Lets try this in terminal...

sudo iwconfig wlan0 power off

If still not fixed, maybe try this?

sudo apt-get install linux-headers-generic build-essential git 
git clone http://github.com/lwfinger/rtlwifi_new.git
cd rtlwifi_new
sudo make install

Then reboot your system, hope this works.


Community Tech Support

Looks like http://github.com/lwfinger/rtlwifi_new.git is a private repo. It's asking for credentials.

Thats weird, it worked for the other member on here, unless something got changed with that REPO. Are you sure its not just asking for your SUDO password?

Sure. It's not the sudo password.

I see prompts for github username and password.

Seems like it's removed. What do I do now?

I created a post earlier. Here it is:

Is the problem I'm facing now was a result of changing the antenna?

I restored to an initial state using Timeshift snapshots. Now all antenna settings were reset.

Now, what do I do to increase my internet speed?

@StarTreker Any update on this?

What is the terminal output of:

sudo apt update && sudo apt install gcc make build-essential git linux-headers-$(uname -r)

@Aravisian Sorry for the late reply. Got busy with moving our house.

I see no output - I mean all packages are already installed.

Found packages for lwfinger here:

I think you do have to have a GitHub account to ask questions etc and the only downside to GitHub now is that it is owned by Microsoft. That's why GitLabs was born as a consequence.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.