Wifi stopped after installing initial 200mb update

hi, first i ap0lgize fr using the number zer0 f0r the letter, this stupid l0gitech keyb0ard wnt type the letter ll.

new t0 Linux, Z0rin and this f0rum. I recently installed zrin 15 32 bit versi0n 0n len0v ideacenter 300 pc stick i
ntel® Atom™ Z3735F Processor (1.33 GHz 2MB)
Operating System
Windows 10 Home
Up to 2GB DDR3L-RS 1333MHz
Up to 32GB eMMC
WiFi & Bluetooth®
WiFi 802.11 b/g/n, Bluetooth® 4.0

everything has been kinda slw, but it was wrking, the wifi was intially wrking, it asked me t run sme updates, which i did, and since than, the wifi isn't wrking. i was able t cnnect t bluetth and share wifi frm my phne. been running cmmands i f0und but nthing wrked

i tried:
sudo apt install build-essential -y

sudo apt update && sudo apt upgrade

i ran a few m0re, but at this p0int i better reach smene wh0 knws what the y are ding. Lifetime windw user, i dn't see device manager, update drivers autmatically, dwnlad and mannual add drivers, uninstall the wifi adapter and reinstall it , i dn't see where i can tell the 0S t0 l00k fr the wifi adapter.

Hi and welcome to the forum.

I thought first we got an extortion letter :wink:

It sounds to me you got something like Broadcom WiFi which needs a proprietary drive.

Could you please open the terminal (ctrl + alt +T) and issue this command and paste the output in your posting?

1 Like

Haha, l0l i have never thught abut h0w thse letters are written, learning Linux-Z0rin and ext0rti0n 0n t0p 0ff that...

i appreciate the pr0mpt respnse, in my years 0f installing emulatrs, VMs, dual/tripple b00ting, writting b00b 0n the calculat0r, i have never 0nce j0ined a f0rum t0 p0st a questin... i never th0ught ppl actually reply t0 help strangers.. s0 thank y0u.

1 Like

00:00.0 Host bridge: Intel Corporation Atom Processor Z36xxx/Z37xxx Series SoC Transaction Register (rev 0f)
00:02.0 VGA compatible controller: Intel Corporation Atom Processor Z36xxx/Z37xxx Series Graphics & Display (rev 0f)
00:14.0 USB controller: Intel Corporation Atom Processor Z36xxx/Z37xxx, Celeron N2000 Series USB xHCI (rev 0f)
00:1a.0 Encryption controller: Intel Corporation Atom Processor Z36xxx/Z37xxx Series Trusted Execution Engine (rev 0f)
00:1f.0 ISA bridge: Intel Corporation Atom Processor Z36xxx/Z37xxx Series Power Control Unit (rev 0f)

i dn't knw whether restartng the machine fixed it, 0r what i c0py pasted in the c0mmand line befre restarting, but it started wrking randmly

You typed it wrong.
Just copy and paste this in your terminal.

lspci <-LSPCI in lower case.

For me it is a tell-tale sign that your driver is not working properly.

i can't just install the driver frm len0v0s website? can i?

You could check but usually manufacturer do not supply Linux drivers.

Curious thing is that I do not see any WiFi card listed here.

Can you try this command then?


i checked, culdn't find the drivers fr linux,
D0 y0u think the wifi might keep ging 0n 0ff randmly?
it was wrking fine when i installed zrin initially, it was the first set 0f updates that l0st the cnnecti0n.

All I can say is that I cannot see the WiFi module in the list of PCI.
Please give me the result of

I need hardware information to trouble shoot.

Totally unrelated, but you might want to check whether your Num Lock is on or not. I had a similar problem with my other Bluetooth keyboard - part of the keyboard becomes ten keys.

i dnt think this brught up that inf either..

z@Z-PC:~$ lsusb
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 002: ID 046d:c52b Logitech, Inc. Unifying Receiver
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
z@Z-PC:~$ c

while yu are here, let me just ask sme quick questins therwiese, i will spend h0urs searching fr these answers.
1- I have a tb 0f micr sd card that zrin isn't picking up in files, i went int "disks" and i saw it there, tried refrmatting it but fat32, but it was taking frever, apprximating 30+ hurs t0 ref0rmat? is there anther methd t0 use the sd card as the primary strage f0r zrin? the pc itself 0nly has 32 gb emmc. Fr example, if i dwnlad Edge brwser, Brave, F0xit pdf, they are fairly large files, is it pssible fr me t0 save all the apps and their data n the sd card and keep the 0S 0n emmc.

2- can i use cl0ud strage - like 0ne drive? install 0ffice 365 suite?

3- searched a way 0f running andrid apk's 0n linux, seems i need an anb0x? and t0 run anb0x, i need smething called snap?

4- z0rin desn't have a way t0 c0nnect t0 windws via RDP? is it pssible?

if u dnt mind, just nudge me in the right directin, where i can find these answers.
Thank y0u

haha, i kn0w exactly what y0u mean. sme keyb0ards have the num keys embeded within the alphabets, but its always either all the numbers 0n 0r numbers 0ff. it wuldn't be just a single letter 0ff. i actually 0pened up the keybard and there is a slight disruptin in the circuit grid, i just didn't have electrical pain 0n me t fix at the time, i usually just use the 0n screen keybard fr a quick search.

Thanks for the info.

You are right, I cannot see any Wifi module here either.
I wonder if @Aravisian could help us to find this mysterious WiFi module.

It depends on how you connect microSD card to your system. Build in SD card reader is a hit and miss. I myself would not run OS on such unreliable storage.

We recommend Mega in this forum.
Linux is well supported and the storage space is generous. Office 356 should work although I've never tried it myself.

For Q3 and Q4, I have no answer.

any chance y0u knw h0w i can map keys? i was using sme prgrams in windws t0 map the m0use buttns and keybard keys , i dn't think i see an 0ptin in zrin



That's also I do not know.
I hope other volunteers in the forum pitch in to help you.

ah, i see. i wuld have t0 buy anther subscriptin thugh, i have a tb 0f cl0ud strage frm my sch00l , thats why i have been sticking with 0nedrive.

n0 wrries, s0mene will stumble upn this p0st. I really appreciate all the help.