Wifi Struggles with the Realtek RTL8821AE

I was looking to try out Zorin as a dual boot with windows but could never get it to install in a way that i could boot into. Eventually i thought i may as well just give it my whole system and later i can get the dual boot for windows going the other way. Big mistake, now i have a basically unusable machine since the wifi on it completely unreliable disconnecting constantly or having sub mb speeds. I thought my wifi was fine when going through the installer and i was getting well over 100 mb speeds with my initial Windows install so im just lost as to what to do. I've tried getting updated wifi drives, checking out other posts on these forums to see if someone else has had similar issues (which i have seen), doing recommended first zorin startup installs to fully build it out more, none of it is giving good results. Any help would be appreciated as Im definitely not experienced with Linux, only really MacOS which is similar in certain ways but not quite as much hands on ability or needed setup.

Can you please detail this, a bit... Did you specifically install drivers marked for RTL8821AE and it did not work?

Yea, i went through this thread Realtek RTL8821AE and tried everything said there as well as some others, but its been hours of attempts at this point so I cant fully remember everything that ive done over the last few days of trying to debug and fix the issue

My most recent attempts had limited wifi and i was trying to do everything listed here as maybe it might make a difference, but then when i restarted i was stuck in the Zorin logo screen forever and so i had to fresh install. Link in question -> Things you must do after installing zorin OS 16

The RTL8821AE driver really should be included in the Linux Kernel - I am wondering if there is a regression in the 5.13 kernel in use.
You might try checking against the 5.8 LongTerm Support kernel:

sudo apt install linux-headers-5.8.0-63-generic linux-modules-5.8.0-63-generic linux-modules-extra-5.8.0-63-generic linux-image-5.8.0-63-generic

Once installed, reboot and start tapping esc or tab to ensure you bring up the Grub Menu - select the option for Linux on 5.8.0-63 Kernel instead of the 5.13.0-40
Once logged in on the desktop, check to make sure that you are on the 5.8.0-63

uname -r

Test network connections...

If this makes no difference, you can remove the 5.8 with

sudo apt remove linux-headers-5.8.0-63-generic linux-modules-5.8.0-63-generic linux-modules-extra-5.8.0-63-generic linux-image-5.8.0-63-generic && sudo apt autoremove

Ill give it a shot and let you know, it'll only take an hour for the first 11 MB file :woozy_face:

1 Like

Are you able to use your cellphone as a hotspot temporarily?

Im not sure of the logistics of that, is it not still funneled through the wifi card if i use my cellphone as a hotspot? a direct connection with USB might work?

This is how I always did it... It is what we try using for installing drivers on members machines that have no Wifi connection.

If that doesn't work you can download the files on your phone and transfer them over.

Tried the suggested solution, and im having the same inconsistent connection issues

Last contact here to see if maybe i was wrong to begin with here. did a tlshw and searched for drivers, found a tool for probing the system overall and seeing known issues or what drivers to get. Heres my hardware list, that might help give a better idea of what else I can try.

In the meantime im continuing to look into it

1 Like

Alder Lake-S PCH CNVi WiFi

Looking this up:

6ECF7 » desktop ASUSTek /
ROG STRIX Z6... 1 [image] Ubuntu 20.04 failed
99435 » desktop ASUSTek /
ROG STRIX Z6... 1 [image] Zorin 16 failed

The Drivers are new for this device and not included in this kernel.
Fortunately... This should be easily solved by using the same newer kernel that I am using:

|26b64d67a9 Snap GUI|[image] Ubuntu 21.10|Dec 24, 2021|works|

Try using the Liquorix 5.17 kernel:

sudo apt update && sudo apt upgrade -y

sudo add-apt-repository ppa:damentz/liquorix

sudo apt update && sudo apt install linux-image-liquorix-amd64 linux-headers-liquorix-amd64

So that did do a kind of fix, now my built in wifi is working but overall wifi quality has not increased and im consistently under 5 mbps. I appreciate your help but i may just have to go back to a windows install or try something else.

A step in the right direction is better than nothing...

Just for certainty, you might open terminal and run

sudo modprobe -r iwlwifi

sudo modprobe iwlwifi 11n_disable=1

In case the default drivers are interfering with the new.

You might test the 5.14.0-1024-oem kernel since some documentation says that works:

This article just came up on the same search and while it doesn't give us a solution; it explains why this is an issue: