Win11 how to access WRE Menu Preboot?

I have a Dell XPS 9520 Laptop which I have both Zorin OS & a freshly reinstalled Win11 23H2 version.

The issue I currently have is that when starting the Win11 on my PC, I don't see the blue Windows Recovery Enviroment (WRE) options menu.

How do I enable WRE via clicking on Windows boot manager in my BIOS menu?

Any help will be appreciated!

Yes surely.
You just need to reinstall with the iso of Tiny11 and upon flashing with Rufus you get an option to bypass both of them. Also it is faster on older hardware.

Please download from this link only. As I don't know the integrity from download on other websites.

1 Like

Assuming you have yet to complete the OOBE ("out-of-the-box experience" AKA initial setup wizard) or are willing to reinstall, this guide worked for me a couple of months ago. Step 13 is where start if you're still at the OOBE.

The exact OOBE screens shown in the guide may not be a perfect match for your version of Windows 11, but the key steps should work if Microsoft haven't patched it out.

You could try to force a local User Account. First You should install it offline, without an Internet Connection.

In the Past it helps to do the following: For that You have to type in the E-Mail-Adress Field something like scammer, spammer, elon musk or and on the Password Field only 1 Sign. But it seems that this will not work anymore.

What seems to work is a Bypass command. Here is a Video what explains it better:

What I used to do the times I installed w11 in a vm was the email address "" and type anything in the password. It will give error and go to the next step, skipping the microsoft account requirement

Another method I know off is using rufus to flash the w11 iso to a usb drive and then installing from there, as it has an option to disable the microsoft account requirement, just like nxtmighty suggested

I think I remember seeing someone ending the wifi process somehow and microsoft account requirement not appearing because theres no internet connection, but it was from the early w11 days and I'm not sure if it still works nor how it worked

I personally would recommend against tiny11 or overall any "windows distro". You don't usually know what they put in them, so it may run without microsoft spyware, but there can be another spyware or malware hidden

And even if it was open source and the malware risk was minimal or non-existent: the risk of things breaking with an update (or just overall deleted stuff coming back) is way higher than on a vanilla windows install, because some new features or system components could expect something to be there but not actually find it. Even if it was safe and worked better in the short run, it will give more problems than a normal windows version in the long run

There's also the fact that most windows distros like that one completely disable windows updates to prevent them from that problem, but that creates a new problem: lack of security updates and software incompatibility in the long run


I actually successfully managed to bypass it via the command prompt by pressing Shift+Fn+F10 keys and then set up a local account.


Do you know how to see and access the UEFI Menu before booting into the OS?

You have to press a specific key before the windows loading icon comes in. That key is usually ESC, F2, F10 or DELETE. However, with how windows's "fast boot" feature works, this can't be done on a normal boot. Instead, you need to log into windows and then reboot (not to confuse with shutdown and then start up), or you can go to the settings app, search for something named like recovery boot options, and from there see if there is an option to boot into the UEFI directly (on windows 10 it is possible, I'm not sure if things changed on 11)

As for linux, the grub bootloader usually has a menu entry for accessing the UEFI, so if you are dualbooting linux with windows and see a menu that lets you choose which operating system to use, one of the options should be the UEFI menu

Earlier back in March, I had Win11 version 22H2 in which I was able to access the UEFI via my BIOS after pressing F12 but now I have the 23H2 version, I can't seem to do that now...

The version doesn't make a difference does it?

So, when the F12 Key is the Key that You must use, you could try the Following:

Completely s turn off Your PC; no Sleep Mode or Stand-By, complete down. Then press the Power Button to turn it off and immediately after that push the F12 Key again and again and again. It feels a bit stupid to do it that Way but it is worth a Try.

Pressing F12 right after turning on the PC does take me to the BIOS, it does not take me to the UEFI after clicking on the 'Windows boot manager'

  1. Totally editing your post to a completely different topic / question is not cool, should be a capital offence.
  2. The terms "BIOS" and "UEFI" are kinda interchangeable the same thing these days, in that modern systems have UEFI instead of BIOS but most people still refer to the firmware control panel as BIOS.
  3. You won't find either a BIOS or a UEFI control panel after selecting the Windows boot loader, because that takes over from the BIOS / UEFI firmware to actually boot into a main OS.

I don't understand You right. When You click on the Windows Boot Manager that starts Windows; that is totally normal. What do You exactly mean with ''UEFI''? UEFI is Your BIOS. BIOS is an older Word and - if You want to have it so - an older System but this Wording still exists. You can call it UEFI-BIOS, too.

Or do You mean the GRUB Menu where You can choose between Windows and Zorin?

1 Like

Yes that currently does happen but previously that was not the case, I didn't need to actually login to my Win11 OS to access the UEFI Menu.

Back in March when I had other previous Win11 issues, I was always able to access the UEFI Menu without having to login Win11 OS.

I want to be able to do just that...

I'm not sure if I'm understanding this right, so let me ask:

When you press the F12 key during boot, what appears on the screen?

Can you provide video of your computers current BIOS and Windows Boot Manager behaviour, and fully explain what you mean by UEFI if not the system firmware control panel accessed via F12?

I have no idea what you mean when you say you can access BIOS but not UEFI and that you expect to get into UEFI by clicking on Windows Boot Manager. That concept does not make sense to me.

I don't have Windows installed, but when my computer first turns on I can smash F12 / F2 / DEL to get either the BIOS/UEFI control panel or a short menu of bootable devices. If I don't, or if I select the main SSD as the bootable device, I get my GRUB menu that lists the installed operation systems - but GRUB, or the Windows Boot Manager, loads after the BIOS or UEFI.

My GRUB does have a menu entry to go into the UEFI firmware control panel, but it's the same control panel as I get from spamming F12 / F2 / DEL or whatever key before GRUB loads.

1 Like

The BIOS Menu appears but on a Dell XPS 9520 laptop that is actually a separate thing from the blue and in white colored text UEFI Menu - where you can access other options as well.

My PC is a Dell XPS 9520 laptop, the way it shows both the BIOS and UEFI Menu is not as simple as having them together.

You usually need to click on the 'Windows boot manager' option whilst in the BIOS Menu right after you press F12 after turning the PC on.

That is exactly what I did back in March but now that I've reinstalled Win11 I'm not sure why it isn't doing the same thing...

Something like this is what appears?

I just looked up the manual of that laptop, and it says that the UEFI is accessed with the F2 key and you said it was the F12 key... aren't you confusing it with the boot menu? Mostly because, well...

That appears in only two places: the boot menu or the boot order in the UEFI. But it only boots windows when selecting it from the boot menu, so with all this in mind...

Could you try again, but this time with the F2 key instead of F12?