Windows 10 legacy install, Zorin 16 UEFI

I'm trying to install Zorin to an M.2 NVME drive, Windows 10 is on an SSD. The W10 installation is legacy MBR, but when I install Zorin as "non UEFI", I can't access the new install. After install, it goes into the restart cycle, tells me to remove the USB I used for install, then boots up to W10 and I can't access the new Z16 install in any way. If I install Z16 as UEFI, at least I can go into the boot menu and select all three of the UEFI boot drives present and Z16 will boot. It will not boot if I select just one of the UEFI's or any other combination of them. I can use the boot menu in the BIOS to switch back and forth so the problem isn't catastrophic but I would like to solve it. My motherboard will accept both Legacy and UEFI at the same time, obviously since I already installed it that way, just wanted to add that so it would be apparent that having both there does not give it indigestion.

MB Gigabyte GA-Z97X-SLI-CF v1.2, i7-4790k cpu, 32gb RAM, M.2 NVME Samsung 970 EVO Plus 500gb, SSD Samsung 860 EVO 500gb; AMD Radeon RX 580 series GPU.

Thanks in advance

Just to confirm - secure boot, in BIOS, is turned off?

Yes. I might add that I am a Linux/Ubuntu novice but I'm willing to learn if it will get me away from Windows which is basically a product sales platform masquerading as an operating system.

You need to install both Windows and Linux in the same mode in BIOS.
Either Legacy or EFI. But not mixed. It cannot be done.

1 Like

If I install Z16 in Legacy, I can't boot to it. While I didn't know about not being able to use both at first, I learned after installing Z16 about 6 times several in Legacy and several in UEFI. Both work but I have to change the boot order in the BIOS. I'm sure the problem is operator malfunction but I can't seem to find my error after extensive searching, reading and trying. Reinstalling W10 in UEFI isn't an option right now and I didn't find anyway to convert it without reinstall. I will rely on my W10 install until I have the bugs worked out on my Z16 install and my knowledge thereof.

You are the second person I saw on the forum having a problem installing Zorin 16 in a legacy mode.

I have Zorin installed on a legacy mode but it is the previous Zorin 15,3 (Lite). This is an old Acer Aspire which has no EFI in BIOS settings.

I think I saw it somewhere. Lemme dig up my bookmarks.
Stay tuned! :tv:

I think I found it back:

Whatever you do, I strongly recommend to create a whole disk image backup with either Clonezilla or Rescuezilla.

1 Like

I heard when you have Zorin OS with off Secure boot and no success. Then start again installation with Secure boot and it fixed that. Something like that.

Looks possible, this is one solution I never saw. Everything said I had to reinstall W10. Will try this evening or sometime this weekend and report back on success.

This will be runner up, it is not something I tried.

Thanks to all.

1 Like

I can again see the video. Then writing again if i missunderstanding on video from youtube. So he sayed he first logoff security boot and installation fail. Then he logon Secureboot and used repair installation and everything working. Security boot automation is setting - Zorin find this function and asking for safety password for security boot.

Back in august i installed zorin with secure boot turned on, it worked fine but it needed extra keys for manual nvidia installation.

1 Like

Reads: not for beginners.


Indeed...even for me it was :woozy_face:. Disabled secure boot back then and it worked fine. Even windows 10 booted without it.


I've never enabled secure-boot.
I installed and used Windows 7, 10, 11 all fine.


Thank you so much. This worked. I've searched changing an MBR W10 install to UEFI off and on for a year and everything I found said I would have to reinstall. I use this computer to trade with and I'm serious about the configuration being just right, I didn't want to do the work to reinstall. The conversion suggested work easily and perfectly. I installed Z16 one more time, UEFI and all is well. Now I can begin the long slow process of configuring Z16 before switching to it permanently.


Wonderful! Enjoy Zorin like all of us...

1 Like

Before you proceed further may I suggest you to create a disk image so that you can recover form any catastrophe in the future?
Clonezilla (CUI) <- Rescuezilla based on this
Rescuezilla (GUI) <-easy for beginners

1 Like

I did create a system image using the onboard (win7) backup and restore. You know, the one that never works when you try to use it. :grin: Maybe I'll give your idea a try, after all, the last one worked pretty good.

I am not so sure if you can use this software to backup the Linux partition. Windows is unable to read ext4 (Linux file format).

Clonezilla/Resuezilla can read/write almost any file format.
When I was using Hackintosh, I used it to backup my macOS disk (HFS+ format).

1 Like

I haven't got anything I want backed up on my Z16 install yet. I have a couple of problems to solve before it can be my go to system. I've got to learn the RTD commands and different formulas for Calc so I can do away with Excel and I have a small bit of software written by a colleague in Python and using SQL server that I find real useful, don't know how that is going to work in Linux. I've got time.