Windows apps installation issues

i got lost completely,can someone give me an easy step by step instruction? firstly this DWM thing they are on about doesnt exist no matter what i seem to install... please help

Here is what I did when I installed Soulstorm on PlayOnLinux:
a. If output of wine --version is NOT wine-6.0, then do steps 1 & 2 here: NET Framework 4.5.2 - #5 by carmar
b. Install playonlinux using Synaptic.
c. Steps on playonlinux are easy - all buttons & no terminal commands:
i. Click Install button
ii. Click Next 4 times
iii. Enter name of a virtual drive - make up a name
iv. Click Next 2 times
v. Choose either 32 bit or 64 bit - if after installation, the game doesn't work on 32 bit, then try 64 bit and reinstall and try again.
vi. Browse to game installation .exe file and click Ok. The .exe will run just like on Windows and MAKE NOTE OF THE INSTALLATION PATH.
vii. Wait for the .exe to finish running - just like on Windows. Make sure you have unchecked any options to run the game at the end of the install. Some GOG installers tend to have this option.
viii. After the installer is done, the system returns you to the PlayOnLinux menu which asks you if you want to create a shortcut. Select the Browse option (2nd option) on that list and browse to the game executable using Home -> PlayOnLinux's Virtual Drives -> Name you gave the Virtual Drive in step iii -> drive_c -> your game installation folder based on step vi.
ix. PlayOnLinux will create a shortcut on your desktop which you can then double-click to launch your game.

I don't know about anything outside of PlayOnLinux but the above directions are the easiest they'll ever be.

2 Likes

It seem really straight forward and my wine version thanks to @Aravisian is 6.0
So I'm gonna jump to step 'b.'

Playonlinux wasn't installed for some reason...installing it..

I still get the error 'Runtime Error (at -1:0):

And then I tried another anothe installation using 32bit option and I got 'Access violation at address 00000000'

What's weird is Studio One for example was working when I first installed ZorinOS light

DOW shouldn't give an access violation. If it does then reinstall Wine - POL is just a front-end, the problem lies with how Wine is installed. I've played Soulstorm, DOW II, Gothic Armada, using POL - no problems with any of them either on install or when running them.

As for the other applications, try searching the net for "Wine access violation" to see what results you get.
Also try asking here: GamersOnLinux

1 Like

i found this im still reading up on the DWM section
after Ubuntu installation Part