Wine improved after the OS upgrade, but partially

After the upgrade to 17.1, using Zorin Desktop on Wayland Windows games that weren't working without changing or downloading stuff now work out of the box. And, with some luck, more that I'd like to install will do the same. It's cool (I literally did nothing for it and their FPS is smooth), but on some pixels on the right screen border act strangely, they show something that's not the game, apparently pieces of other previous frames.

They change as I play and sometimes they also start blinking. Is this behavior harmful for pixels? Because they blink fast so I wonder if playing with this effect damages my pixels on the right.

With LED and LCD and all these different screens... it's hard to say if it will damage the screen or not. I would place the safer bet (as well as want to be rid of the annoyance) and consider it potentially harmful.

What graphics are you using?

1 Like

AMD® Rs880.

This leads you to trying out different kernels. :grin:

1 Like

Heh, I never touched a kernel manually, I just limit the kernel use to what Update Manager offers me and what Zorin OS Core chooses for me :smile:. But right about kernels, is it normal that users are proposed to install even Linux Kernel Headers for development beyond the common and safe ones? I disabled the options to check for advanced updates but I often see downloads for development stuff that of course a common user wouldn't need.

Technically speaking, all Linux kernels are expected to be safe. And regressions are not supposed to ever happen.

Sometimes a user with specific hardware will need to try different kernels. It is very easy to undo, should a kernel really fail you - boot to Grub Menu > Advanced Options and select Zorin on... the previous working kernel. Then remove the new kernel.

Which kernel are you on now?

uname -r

The AMDRs880 dates from about 2011, correct?

1 Like


I don't know, on Wikipedia I read 2007, Gemini tells me 2009, then I who hate these differences for such simple answers that I find on the Internet I say 2008 :smile:.

Well, we have established that it is old.:stuck_out_tongue:

This suggests that an earlier kernel may be best for you.
Quick question, though... On the Xorg desktop, does the right screen pixel party happen?


On Wayland it happens on both games that I tried but on Xorg one gives a memory access violation error while the other works. For short, some games work on Wayland, some others on Xorg. The bad thing is that since I change games often I can't simply switch to other desktops every time, because it's not convenient. I'd also need to restart my laptop to do so since I don't have the gear button on the log in screen after a standby.

Initially, it sounded like you are getting better support for your games over-all on Wayland. But there was an odd display issue of the pixels on the right side.

If there is a graphics issue, it may mean that your trend will be better support on Wayland and that this is not a display issue, but a graphical one.

If the graphics are fine and some games work on Xorg and some work on Wayland, then we need to focus on Display.

What we have established so far is that your graphics card is on the older side. It is AMD so the graphics drivers are included in the Linux Kernel.
What about trying the 5.15 kernel?

sudo apt install linux-image-5.15.0-83-generic linux-headers-5.15.0-83-generic linux-modules-5.15.0-83-generic linux-modules-extra-5.15.0-83-generic

Using the Grub Menu > Advanced Options for Zorin, you can choose which kernel to boot into.

1 Like

I'll try this one, thanks :slightly_smiling_face::+1:. Did you notice that on the second screenshot the 4 genohunters are not where they should be :smirk:? They should be right at the center of their respective box. It's like if a part of the game detects a smaller resolution or aspect ratio and places them wrong :smile:.

That also implies a Graphics driver issue.

1 Like

I installed that kernel but how do I try it? I tried sudo reboot -r and sudo reboot -r 5.15.0-83-generic but both tell reboot: invalid option -- "r" so should I follow the solution of the post How to get to the GRUB menu at boot-time??. I always prefer a simpler and safer way for these things instead of changing files manually like the solution at the above post, the 2 commands were supposed to make me try that kernel without changing the default one in use.

This would be sudo shutdown -r as the -r flag says to restart.

Try hitting the esc or tab key starting at boot to pull up the grub menu.

1 Like

Only once or holding? Because I already bricked my OS once, I was holding F2 to access the BIOS and I started entering some weird characters. I had an INCONSISTENT FILESYSTEM that luckily I fixed easily but in fact there's the risk that I start entering stuff on the boot screen with the blinking cursor and so I do the same mistake.

Tap it like you are playing Mortal Kombat.

1 Like

Hehehe, done :smile:. But I don't see the kernel choice, I only see the devices boot choice, just a section of the BIOS settings. If you meant to make me open the BIOS settings then I already know how to do, with my laptop I have to hold F2 while it's booting up. I remember that one day I could load the kernel selection from the BIOS but now I don't remember where :person_shrugging:.

Aravisian was referring to how to view the GRUB menu at boot time. :wink:

1 Like

Oh, ok, then how do I open the kernel choice? Should I follow the other post that I found or can I just load the kernel that Aravisian suggested without changing the default one in use? Like Windows safe mode :grin:. I'd prefer to load a kernel temporarily for the next session rather than setting it as default, but if I have no other way to access the kernel choice menu I'll edit the files as explained in the other post.

It is under advanced options in GRUB menu - you should get a list of earlier kernels, unless updates have removed them. If you have Synaptic Package Manager installed you can do a search for kernels to see what is installed (the box to the left will be filled in if installed.

1 Like