WLAN issues

Hi,
...and me again :smiley: I have observed several WLAN problems in the last few days:
Normally WLAN is displayed in the settings. In some situations (like right now) this option is missing. A connection with something I could not find yet.
In addition, I can not activate the WLAN hotspot in principle. There is an option to do so, and when I select it, it seems to work. However, when I then want to connect to the smartphone, no network can be found. In addition, I could also (despite that actually the hotspot is displayed as active) use the mentioned option to activate.

You will have to be a little more descriptive as to what you mean by WLAN being on but not showing. Normally the indicator is hidden only when the wifi is off. Depending on battery and the age of your laptop this may happen automatically. You can adjust the settings in tlp to remove the battery saving from the wifi card, which will most likely solve the issue of the wifi indicator not appearing.

Some networks may not appear on your laptop, it depends on what the wifi card supports. Older laptops may not recognize the 5GHz band, while newer ones may disregard the 2.5GHz band, depending on the standards supported (a/b/g/n). Hidden networks you must know the SSID in order to connect, otherwise it may not pick them up.

When you provide the network through the Hotspot feature, you are unable to "listen" as a laptop or phone does to connect. Essentially you are running as a router. You will have access to any device connected to the laptop, but in a different manner than what your applications are looking for. Laptops still come with only one wifi card and the limitations of that hardware do not provide the same functionality as a phone. Normally because the card is limited to one radio for wifi and one for Bluetooth. Your phone has a wifi card with at least two radios for wifi (can send and receive on both) which is what allows for multiple connections and reduces loss of connection while moving (similar to the mobile radio setup). You may want to try the Bluetooth connection if your laptop supports it. Otherwise you will need an external wifi connection for both the laptop and phone so they are on the same network and able to use the Zorin connect.

Thanks first of all for your answer. I already talked to an IT expert yesterday about this problem among others, he helped me with the trace back from this to the driver. Accordingly, I have contacted the motherboard manufacturer.
But to clear this up briefly: I use a very powerful and new PC, so I can exclude energy saving options.

That I - when I use the hotspot - can not search for WLAN, I have already noticed. But that doesn't matter to me, since I only need the hotspot, and I need it urgently. I'll try to describe my problem again in more detail, since I don't know if this problem can be traced back to the driver:
In most cases, the WLAN option is normally present in the settings. Then I can also activate the hotspot. When I run this option, everything also seems to work, only my phone dont finds the network. The connection via the QR code generated by Zorin is also not possible.

Then it is your phone that doesn't support the network standards used.

If you would be able to tell us which wifi card you have, we may be able to point you in the direction to get the correct driver installed and possibly solve all of your issues. The proper driver may give you the ability to modify the frequency used for the hotspot. Try lshw --network. If that is wrong you can use the --help to find the correct flag for network or wifi devices. If you post the results here we may be able to better assist you.

I hardly think so, my phone is relatively new. In addition, my tablet (1 year old) does not find the WLAN.

   Beschreibung: Kabellose Verbindung
   Produkt: MEDIATEK Corp.
   Hersteller: MEDIATEK Corp.
   Konfiguration: broadcast=yes driver=mt7921e driverversion=5.13.0-30-generic firmware=____010000-20220110230951 ip=10.42.0.1 latency=0 link=yes multicast=yes wireless=IEEE 802.11

The driver is up to date and the correct one, but there seem to be problems with this driver under Linux in general, which is why I contacted customer support directly. I'm afraid you won't be able to help me as much here, at least with the intermittent failures.

A lot of what I'm reading for this wifi card is saying you need kernel above 5.12. Currently Zorin 16 is on the 5.13.0-30 kernel, so may require the firmware of 5.14 kernel (the other commonly mentioned kernel that people had success with).

Recommends attempting to install the firmware and provides the instructions how to. Others have upgraded the kernel to 5.15 in order to get full functionality. One option is to turn off wifi 6 support (try the bios) before attempting a kernel upgrade. Going to the 5.15 kernel will be possible, but not recommended for most. Because you have the latest in hardware, it may be the only way to get the full functionality.

This is the best option until a driver is created for older kernels. I would attempt the firmware first (if turning wifi 6 support off doesn't work) and will impact the OS the least. If that doesn't do it or before creating more issues, then you will need the full 5.15 kernel. Waiting for the manufacturer to provide a driver may be some time.

For future reference, though you may feel that you have been posting a lot, not every member will have read your issues.

Please be sure to include your system specs as well as at least the model of any other device involved with the issue. Though it may be clear to you what is being relayed in non specific statements, the rest of us (evident by my guess work in this thread) have no clue what hardware you have, what peripherals or other devices involved are or how old.

This made it both difficult to assist you and made me look like i had no idea what I'm trying to assist you with (which is far from the truth). Hence my request for a more detailed explanation of your issue.

I tried the kernel update, but both version 5.15.0 and the latest (5.16.x) did not show the WLAN adapter. On the contrary, the Bluetooth adapter is also no longer recognized (but I mean that this was already there shortly before the update). Also, the update caused some problems (the screens were not recognized properly, which resulted in the first screen having a completely wrong resolution and aspect ratio, the second one was completely off), which is why I went back to kernel 5.13.
And with your tip that I should disable Wifi 6: I have unfortunately not found a function in the BIOS to do so.

Here briefly my PC data (had not sent in so far, because I actually thought that this is not necessary):

  • Gigabyte B550 Aorus Elite AX V2 (rev1.1)
  • AMD Ryzen 9 5900x
  • 32 GB RAM @ 3000MHz
  • 2060 Super
  • 1TB (NVMe) + 1TB (NVMe) + 500GB (SSD) + 1TB (HDD)
  • Zorin OS 16 Core