Won't Etch (BalenaEtcher)

This is what I get:

Any ideas please?

Hi, it may be the image file is corrupted under download. Please try re-download.

1 Like

Before using Etcher, please check sha256 for your .iso file, to be sure that everything is fine :

Zorin OS 16 Core 64-bit eabd2a222175f3556f277a0722664af1f11230285c4ce6bf69984ac40c48b1c3

Zorin OS 16 Pro 64-bit 1addffb6100a5ba340266b709b367ded7094aa563143dd98ba577aaf00498590

You can use this tool :


Also, you can try alternatives other than BalenaEtcher. I prefer Unetbootin and I never use Balena.
Multiboot is good and for Windows Users as well: Rufus gets a lot of praise.

Judging from what I see in the screenshot, OP is trying to make a Zorin installer.
I think the consensus is that Etcher is the only one that can make a installer for Zorin16.

I think that was a limited case and only affected some people. If Balena is not working - I still think trying other etchers is viable.

Oh, was it?
I tried Mint stick, Rufus, and gnome-disks - nothing worked other than Etcher.

Yes, in my testing, Unetbootin worked each time without any problems.

This one is a bit of a trade off- as BalenaEtcher also is known for damaging USB sticks. For some people it is what worked for getting Zorin OS installed, but I would personally still consider it a last resort.

1 Like

Ah, OK thanks.
I tried Unetbootin but I could not take its user interface.
Fonts are too small for my ageing eyes and there was no way to enlarge them :frowning:

I second that.
I remember seeing it when I accidentally tried to flash a partially downloaded image.

I did not think of this-- and I have done this on several occasions. Which makes sense... you can tell by many of my posts - Big Huge Hurry...
Always check that the download has actually completed before trying to etch.

1 Like

Thank you everybody for your kind interest and suggestions. The checksum of the download was correct, so no corruptions. I trued unetbootin, and, although Zorin was not mentioned in the list, everything proceeded as expected and I ended up with a bootable USB stick.

Zorin is installing on my HP Envy laptop right now!

Thanks again.


That would not happen if people took time to check the download file SHA256 against the published SHA256 checksum :roll_eyes:




3 posts were split to a new topic: Run GAMBAS on Zorin OS

This topic was automatically closed after 3 days. New replies are no longer allowed.