Wrong keyboard layout when logging in

Hi, i installed for the second time ZorinOs. By a mistake i chose wrong keyboard layout - Polish programist DVORAK instead of polish legacy. After the instalation process finished i uninstalled dvorak and went with legacy, everything works just fine. Problem occurs when i shut down the system, turn it on and i have to login to my user account, somehow layout switches to DVORAK. I tried editing files with NANO by sudo nano /etc/lightdm/lightdm.conf.d/50-my-config.conf and then adding [Seat:*]
session-setup-script=/usr/bin/setxkbmap -layout pl -variant legacy. I also tried sudo nano /etc/X11/xorg.conf.d/00-keyboard.conf and then Section "InputClass"
Identifier "system-keyboard"
MatchIsKeyboard "on"
Option "XkbLayout" "pl"
Option "XkbVariant" "qwerty"
EndSection
But unfortunately it doesnt work and the Dvorak is still there when logging to the user acc. After i am logged in everything is in legacy. Any1 have any ideas?

//////
I found the solution, as it appears it was extremly simple: i just checked keyboard files by cat /etc/default/keyboard
and found that it is set to dvp instead of legacy. afterwards i edited it in nano to legacy and it works just fine.

1 Like

A post was split to a new topic: Keyboard layout wrong at install