Xbox wireless adapter for Windows support?

I have 2 Xbox One controllers. Both work out of the box on Zorin OS 16 when plugged with the USB wire.

I tried to use them wirelessly by plugging this two adapters I own:

  • A big one called "Xbox Wireless Adapter for Windows"
  • A small one called "Xbox Wireless Adapter for Windows 10".
    Both don't work.

I researched and found xone but I would like to know if it's the good way.
I also found xpadneo but unless I'm mistaken it only works via Bluetooth and not with Xbox dongles.

Do you have any recommendations about how to make my Xbox controller work wirelessly? I don't want to damage the USB operation and if there is a risk or it's too complicated to install I prefer to avoid...

Thanks :slight_smile:

I'm not sure about xbox controllers, but, for ps3 controllers I didn't need to download anything, this is what I did:

Open the settings app, go to bluetooth, plug in the controler wired, then you'll get a pop-up window asking if you want to sync the controller. Click on yes, and after unplugging the controller from the pc it should stay connected

1 Like

I don't have a Bluetooth adapter on my PC, it's why I would like to use my Xbox dongles.

When you plug in, open a terminal and issue lsusb - what do they register as? Should be something like: Bus 001 Device 002: ID 3151:3020 YICHIP Wireless Device (my cheap AliExpress mouse).

Had to dig around to see what was going on with one of my USB devices - turns out it was being assigned to a braille display?... weird.. So, uninstalled that driver - worked like normal (not implying the braille driver is a fix in your case). Or, could be blacklisted somewhere..

Hi :slight_smile:

I would like to try but I'm not sure how to install it (I'm a Linux beginner).
The Github page says:


  • Linux (kernel 4.15+ and headers)
  • DKMS
  • curl (for firmware download)
  • cabextract (for firmware extraction)


  1. Unplug your Xbox devices.
  2. Clone the repository:
git clone

  1. Install xone:
cd xone
sudo ./ --release

NOTE:Please omit the --releaseflag when asked for your debug logs.

  1. Download the firmware for the wireless dongle:

NOTE:The --skip-disclaimerflag might be useful for scripting purposes.

  1. Plug in your Xbox devices.

I don't know if I have the prerequisites but I typed
git clone
in my terminal and I get this message:

Do I really have to install this way?

I plugged my two dongles:
The big 1713 (older):

and the small 1790 (newer):

This is the lsusb result:

Bus 001 Devis 005 is the big.
Bus 001 Device 006 is the small.

Thanks :slight_smile:

What time is it for you? I'm french, for me it is 11:14 AM :wink:

OK, I thought you were from US, (5 AM) ! :wink:


Thanks, I will try

It works perfectly! I just tried with the big one.

Thanks a lot, really ! and thanks a lot to Xone developers :smiley:

1 Like

I am in the U.S., however lol ..

Microsoft Wireless XBox Controller Dongle - That's what I found on the status of the big dongle using something called xow and WLAN.

Microsoft Xbox Wireless Adapter for Windows - The litt'ln doesn't appear to be working.. Don't have one to play with though..

But, I'm late to the game - glad you got it working though! I was happy to get my PS3 controllers working with my RetroPi build :grin: Feels weird playing Soic Adventure with a PS3 controller :joy:

1 Like

Thank you anyway for your research :slight_smile:

1 Like


Two days ago, I had a small problem: the controllers seemed to be well connected (the X button lights were on) but were not detected in Steam.
I checked with Gamepad Tester: also not recognized.
I turned the controllers off and on again: same, restarted the PC: same, then I just unplugged and plugged in the receiver: and problem solved.

So it wasn't too bad but I hope it doesn't happen too often...

When your controllers were working were you using the big or small adapter? I just installed xone and I can't get my small adapter to work at all. Not even the light turns on. The same adapter works fine on Windows though.

1 Like

Hi, just the big:

I bought the new Xbox "Starfield Controller" (equal to the game), but it was not able to connected under Bluetooth, either with an original Wireless Dongle.
But this worked for me: Today i installed a new Firmware under the help with a Windows 11 Surface Laptop 3; Problem resolved!!!
Now my Crontoller is connected via Bluetooth WITHOUT ANY DONGLE on my machine with ZORIN OS 16.3 Pro!!!

Nice greetings from Cologne, Germany

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.