XFCE I must force sleep on login, now will not wake

I have a horrible conundrum. My lousy HP zBook 17 laptop has built in Intel graphics as well as an Nvidia Quadro card and no ability in the BIOS to shut down the Intel card. This causes a garbled screen on login and forces me to close the lid after logging in to make it sleep, then when it awakens all is good. Or at least was until today. I am using Zorin Core with XFCE. Now it will only work when I go to the Zorin Desktop (Gnome?).

Does anyone have any idea how I can get back to using XFCE? I really like the speediness and features of that desktop environment.


In terminal, you may be able to use

sudo nvidia-xconfig

To set Nvidia settings.

sudo apt install nvidia-settings

You can try removing .Xauthority and .ICEauthority from your home folder and any .nvidia-settings files in your home folder, then try logging out and in.

Last ditch - Find your Nvidia driver version so you know what drivers to download

lsmod | grep -i nvidia


lspci | grep NVIDIA

and purge and remove all nvidia drivers from your system. Then add ppa

sudo add-apt-repository ppa:graphics-drivers/ppa

and install the driver that you got from the command Grep above (Just the three character number, no decimal places)

sudo apt install nvidia-driver-(DRIVER-NUMBER-GOES-HERE)

thanks for your reply @Aravisian !
Should I be doing this under the Zorin desktop? I can’t log into the XFCE desktop…

Also I’m not using any Nvidia drivers. I’m using the Nouveau driver. Should I try switching to the Nvidia driver? I didn’t have much luck with those drivers. Made dual monitors not work, and I had been happy with Nouveau up until now.

Yes, from Gnome.
Clearly, I need to do some learning, because I am unsure on this; But… I am under the impression that the drivers I referred to above are Nouveau. They are called “nvidia” because they are for Nvidia, but the only time Nvidia Drivers are used are when you use the Proprietary drivers or get the drivers directly from Nvidia.
Take this with a grain of salt, though.