Garbled monitor at boot until I close laptop lid and reopen it

I have the wierdest issue. I can totally live with what I have, but I suspect someone will know exactly what the issue is and be able to help me with a fix.

When I boot to 15.3 my screen is garbled with only a few colorful dashes splashed across the top of the screen. If I close the laptop lid (HP z-book), wait a few seconds then open it, my desktop magically appears and I can log on.

So worst case senario is that booting sets me back about 30 seconds. But it would be nice to resolve the issue.

I am using the nouveau driver as I can’t get the nvidia drivers to recognize my second monitor. I don’t need the nvidia drivers anyway as a second monitor is more important to me than gaming.

Thanks in advance for any help. Love the distro!

What all drivers are listed under Zorin Menu -> System Tools -> Software Updater -> Settings -> Additional Drivers? If there are several, you can play around with selecting different ones to see if the problem gets fixed.

thanks for the reply carmar. I have tried all the Nvidia drivers but Zorin won’t boot unless I choose the nouveau driver. I would like to know what is happening when I close the laptop lid that makes the screen refresh then show my log in screen. Is it suspending? hibernating? If I know then maybe I can force the system to automatically do that when booting up.

It is suspending when you close the lid.
Can you try the following to see if either of these fix your issue (one at a time)?

  1. sudo ubuntu-drivers autoinstall
  2. sudo apt install nvidia-current-updates nvidia-settings-updates

Yikes! I’m going backwards. I tried

[quote=“carmar, post:4, topic:2240”]
sudo ubuntu-drivers autoinstall
[/quote] now I can only boot by going to advanced options and choosing the recovery mode. HELP!

Follow the instructions here: [SOLVED] Black screen after install
Same as steps 1-3 here:
and let us know if that works.
Then try #2 in the earlier post: Garbled monitor at boot until I close laptop lid and reopen it

Update - I saw some information about the Discrete Graphics Mode in BIOS possibly being related to graphics issues. Can you try toggling your settings for that, then using the sudo ubuntu-drivers autoinstall and then seeing if you can boot without having to resort to the lid closing? Your drivers are the issue and the nouveau doesn’t seem like the long-term solution here, otherwise you wouldn’t have to do the lid closing just to get it to work.
These sites show different issues but are all graphics related:


I tried the “sudo apt install nvidia-current-updates nvidia-settings-updates” and got:

Reading package lists… Done
Building dependency tree
Reading state information… Done
Package nvidia-current-updates is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package ‘nvidia-current-updates’ has no installation candidate
E: Unable to locate package nvidia-settings-updates

I’ll try rooting around in the BIOS and see if I can find anything related to the Discrete Graphics Mode and I’ll get back to you.

After looking at all the docs you suggested and doing some research I think you are absolutely right. It seems to be an integrated video (intel)/discrete video (Nvidia Quadro) issue. Unfortunately I can’t find any way to disable it in BIOS on my HP Zbook 17 G6. I can find a lot of info about doing that on the G3 but it doesn’t apply to my laptop. Given that I am enjoying Zorin so much and it is only a small hassle at boot I’m just going to live with it. I appreciate your help though @carmar

1 Like