Xfce4 Panel will not launch

Attempt to launch causes error message:
GDBus.Error:org.freedesktop.Dbus.Error.ServiceUnknown: The name org.xfce.Panel was not provided by any .service files

I’ve tried some of the solutions offered in the task bar problem without success.

Can you try reinstalling XFCE4 using Synaptic to see if that fixes it?

Odd, that normally is a root error.

What happens if you hit alt+F2 and then input

xfce4-panel

Tried Synaptic. The package below would not install.
xfce4-equake-plugin:
Depends: xfce4-panel (<4.13) but 4.14.3-1~18.04 is to be installed

The error message repeats on launch:
GDBus.Error:org.freedesktop.Dbus.Error.ServiceUnknown: The name org.xfce.Panel was not provided by any .service files

I have to use the Microsoft search as alt+F2 does not work on the S145.
No result.

Regarding Aravisian’s suggestion, try Alt+Fn+F4 (if you have a Function “(Fn)” key).

Regarding Synaptic, can you go to Custom Filters -> Broken and see if anything is listed? If it is, get Synaptic to Fix it.

Hmm. Wondering if I should uninstall. I have the deb. package but that won’t install either.

You can try uninstall. When you are ready to install again, just install directly from Synaptic and any Recommended for Installation packages too.

You would have the 4.14 version of xfce4-panel.
I just opened synaptic and the xfce4-equake was indeed listed. It is in the Debian Stretch repo.

Done. No change. Same error message,

GDBus.Error:org.freedesktop.Dbus.Error.ServiceUnknown: The name org.xfce.Panel was not provided by any .service files

Ok. Well, it now launches and will not alter the existing panel, but it has installed a panel which can be moved around on the desk top but which I cannot remove, despite using Panel to do so. No idea what to do from here except perhaps back up docs and reinstall Zorin Package.

Uninstalled Panel. Shut down laptop. Desktop cleared of unwanted panel. While I don’t like to give up on these things, I have a got a functioning OS that isn’t collecting my navel fluff at every given moment, and if it doesn’t have the exact appearance that I might have liked, that’s not the end of the world.

Thanks for your help folks!

You had two panels? Are you running Zorin Lite or Zorin Core?

Running Core. I removed Panel, reinstalled it from the Debian Stretch repo, attempted to use it, and it placed a task bar about three centimetres long in the top left corner of the desk top, but would not let me remove it. I uninstalled Panel and restarted the laptop. Offending taskbar (panel) gone, reinstalled again, launched, error message:
“Could not get lock/var/lib/dpkg/lock-frontend-open (11:resource temporarily unavailable”.

Ok, I think I am starting to understand.

Zorin Core uses Gnome Desktop. Zorin Lite uses XFCE4 desktop.
You installed the XFCE4-panel on the Gnome desktop, which most likely still had the Gnome-Shell running with its own panel.

When you add a new XFCE4 Panel, it is essentially a Blank. It is just as you describe, a small box placed on the desktop. In order to configure it, you must move it to the location you want it to be in. For example, the side, top or bottom (On bottom is the Gnome Panel, though).
Right click that box to open the XFCE4 panel settings. You can select its size; Length and Height. There are many settings available in the xfce4-panel settings window that opens. Unlike the gnome-panel, XFCE4 panel is highly configurable on Right Click.

If it is running the XFCE4-panel and you want it gone, you can run

killall xfce4-panel

This error means that an installation is in progress and you cannot get a lock on dpkg while it is currently locked by the running installation.

All of the above said… You were running the XFCE4 panel on the Gnome Desktop instead of XFCE desktop. While XFCE4 panel can run as a standalone package, which you did get it to do, it would be running in addition to the Gnome Shell with its panel and many dependencies for the xfce4-panel would not be present. This means that XFCE4-plugin packages, such as the equake package, would be not work.

I am speculating that you installed the panel in order to have access to the equake plugin?

Actually all this started because I wanted to change the appearance of the task bar. On Zorin Core 15.2 (which is running on my MacBook) I can use the Panel app to change the appearance of the task bar. (My MacBook is in it’s death throws, hence upgrading my Lenovo laptop to Zorin 15.3)
I tried to launch Panel on the Lenovo, and it wouldn’t. The Panel app was in the install list, I had not downloaded it at this stage, it was the version loaded during putting 15.3 on my Lenovo. It was this preinstalled package that would not launch, so our attempts to address that are about the version included in the 15.3 download. So I’m a little lost about where to from here.
I was not worried about the earthquake plug. I just wondered if it might have associated dependencies that might affect install.

And you are running Core on the Lenovo notebook, too, right?
I am not sure what Panel app you are referring to. (Gnome-extension, maybe?)

On XFCE, you can configure the panel pretty much however you want from right click. You can set it opaque, transparent, translucent… You can add a background image (You can search for panel backgrounds and find one you like or make your own.)

If you installed Zorin Core 15.3 on the Lenovo, you would not need to launch the panel. It autostarts as part of the desktop environment. If you need to refresh it, you can do that on the Lenovo with alt+F2 and enter in

r

If you installed Zorin Lite 15.3 on the Lenovo, then the same applies: The panel would autostart as part of the Desktop Environment. If it is not starting, then something is wrong. It can be refreshed with

xfce4-panel -r

For the panel. If you want the Desktop Environment to restart, that is

xfdesktop --reload

You could log out on the Lenovo and check at the Log In screen the icon to change the D.E. and check what is selected there. You may ensure you are not logging into Wayland.


It’s the Panel app included in the install, the one with the wee mouse.

I just checked, running core on both laptops, same app on both computers, but only works on the MacBook.

The panel (task bar) is there, its just that it doesn’t respond to being customized. So I launched the preinstalled ‘Panel’ app and it won’t launch. So this is a cosmetic problem not a running problem.

Hitting alt+F2 doesn’t work on the Lenovo, it has the Microsoft window key on the key board which does not allow the function that you are suggesting.

Ok that is the XFCE panel you are seeing listed in Software.
That is not part of Gnome or Zorin Core. That is included in Zorin Lite. If you are running Lite, then the panel is already active, so you cannot launch another instance. Clicking the app would try to launch the panel, it does not launch a configuration window for it.

What happens if you Right Click your Panel on Zorin?

Could you please enter in terminal

inxi -F

And paste the output here?