You again, Sofware Updater 😡?

You know, I'd really like to set that Software Updater never show up as soon as I turn on my laptop, it's a bit annoying, I check updates manually and it's not said that as soon as my laptop is turned on I want to update or that I'm online for it. Even setting Never on when to check it anyway shows up, then if I don't wish to update some things it will open again next time, too. Moreover, it opens again some times. Windows was much better on customizing this. Can someone please reply here so who needs it understand at once and easily every way to fix? Better listing ways step by step and with Note: for any possible warning. Reading other guides I was overwhelmed by message over message and much of explanation :point_down::dizzy_face:. Then even for me Never was working, probably because as I'm not updating certain stuff it keeps reminding me, but I don't want it :triumph:

If you truly want update notifications removed, you can run

sudo apt remove update-notifier update-notifier-common

1 Like

But does it prevent the Software Updater window to appear every time? Because I can accept notifications (they disappear in few seconds) but not the window.

removing update-notifier removes the entire program which gives you those "you have an update" notifications. this doesn't mean you can't update though

Alternatively, next time the window comes up, hit settings, and set "Check for updates" to "Never"

1 Like

You may have to disable or remove it from startup apps as well.

1 Like

No, there are only SSH keys agent, im-launch and Startup Sound, nothing about updates.

Thanks, looks like that now the window don't appear anymore :smile:.

1 Like

Hell, no, it still does :rage:, now it's enough, on Windows you never have this annoyance. I disabled notifications, I set Never, I set whatever you can but it still does, this way I'll always have to close that window :expressionless:

ohhh yes you do.... on a massive level. And it downloads and installs without your permission, too.

All you need to do is run your updates and if there are packages that you do not wish to be upgraded, mark them with apt-mark hold.

1 Like

When I set it to never search for updates it never did and Windows Update has never displayed updates available, really, then I don't know if it installs something in background, I never checked nor thought about it.

I looked further into this and I believe I have found the answer.
You have the update-manager set to 'never' and it is actually working.
However... Zorin OS also comes with Gnome-Software preinstalled.
And Gnome-Software is repeating the update manager's action, thereby kicking in the notifications again.
You should be able to quell Gnome-Software with gsettings:

gsettings set org.gnome.software download-updates false

But be warned... In searching this, I found several bugs with Gnome-Software that causes this to not always work.

It is also noteworthy that if you use Snap Packages, they will also continue this trend - and there is no way of disabling it.

I agree with your frustration. If the user sets the update info, then another Gnome Application should not take it upon itself to override it with the excuse of "But it is in the users best interests..." like Gnome does.

1 Like