Disable Software Updater at startup

Hi everyone,

I was trying to disable the Software Updater from launching at start time and downloading updates. From Software Updater > Settings > Updates, I tried setting “Automatically check for updates” to “Never” but it still pops up everytime to inform me of new updates available. I’ve also looked into the “Startup Applications” but I cannot find it there?

The reason I want to disable this is because I already run this command myself as a habit: sudo apt update && sudo apt upgrade and sometimes they get in the way of each other.

Thank you!

You do this at your own risk: Alt+F2 -> type in ‘dconf-editor’ without quotes. In new window, search for ‘update-manager’. Under the folder of results you get a setting for ‘enable notifications’ which you can toggle off. I don’t know if this works - I haven’t tried it.

If you don’t have dconf-editor, install using sudo apt install dconf-tools

Switching the updater to never should work.
You can also switch off notifications from the Software Updater in in the main settings application under Settings->Notifications.

1 Like

Hi, thank you both for your help!

I think I’ll go with the least risky option and disable the notifications in addition to the “never update” setting. I’ve only disable this a couple days ago so I’ll stick with this configuration and see if it works :+1: