"You are in emergency mode" when I boot Zorin

Hi, I have a dual-boot Windows 11 and ZorinOS 16 setup. Today when I tried to boot into Zorin, I was taken to emergency mode where I could only see a command prompt thingy, which I cannot exit from (typing exit or reboot bring me to the same place)

I searched for solutions on the internet where people pointed UUID change as the issue but that was not in my case.

Now, I am really in a fix. Can someone please figure out the issue?

I have attached the blkid and etc/fstab outputs.

(I commented the /boot/efi and /swapfile lines in etc/fstab file, read somewhere to comment the lines you don't find in blkid)

Did you try fsck.ext4 /dev/sdb5 ?

1 Like

Shows this.

I don't understand this. This doesn't explain how do I repair the file system or escape the emergency mode(rebooting brings me to the same thing)

Hi, so I ran journalctl -xb to see the logs and found the /dev/sda4 partition to be the problem

Then I ran fsck -y /dev/sda4 then reboot and got it fixed!

4 Likes